PROBLEM CIFS - File Access issue

Discussion in 'Sharing' started by minnus, Dec 30, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    minnus

    Member Since:
    Dec 30, 2012
    Messages:
    2
    Message Count:
    2
    Likes Received:
    0
    Trophy Points:
    0
    minnus, Dec 30, 2012

    Hello,

    I have an odd problem.

    For starters, I have FreeNas 8.3 installed with VirtualBox, on a Windows 8 box. It is configured with 5GB of RAM, 4GB of virtual HDD space, and access to 4 physical disks.
    The 4 Disks are set up in a ZFS, RAID-Z2.

    I enabled CIFS using the default options, and the user accounts are configured for access. Computers have no issue logging on and transferring files on and off the share. Performance is acceptable/expected.

    The issue comes in when an item is opened or executed. On Windows 8 boxes (I unfortunately don't have other OSes to test with), when opening (for example, .mp3) or executing a file (for example, an installer .exe), the linked program (so for mp3s, any media player) is in a permanent state of loading while Explorer on Windows essentially freezes. If I leave the items to load perpetually, Windows will eventually freeze (probably around 30-40 seconds of waiting later). If I close explorer and the application, the computer will not freeze.

    Anyone have any ideas as to what the issue is? Any advice is very much appreciated!
  2. Offline

    cyberjock Forum Guard Dog/Admin

    Member Since:
    Mar 25, 2012
    Messages:
    13,220
    Message Count:
    13,220
    Likes Received:
    674
    Trophy Points:
    113
    cyberjock, Dec 30, 2012

    You're the 3rd person I've seen in the last week to have issues with Windows 8. I do know that Windows 8 uses some new SMB version that's supposed to allow for performance increases in certain situations. I would look around and see if there is a registry setting you can try to disable the new SMB version.

    Aside from that, my only other advice is stop using Windows 8. If this is a problem with SMB/CIFS it could be a quick fix or take years. I believe when SMB 2.0 came out(Vista/Server 2008) it was something like 2 years before Samba supported it officially.
  3. Offline

    minnus

    Member Since:
    Dec 30, 2012
    Messages:
    2
    Message Count:
    2
    Likes Received:
    0
    Trophy Points:
    0
    minnus, Dec 30, 2012

  4. Offline

    madmax Newbie

    Member Since:
    Aug 31, 2012
    Messages:
    56
    Message Count:
    56
    Likes Received:
    2
    Trophy Points:
    8
    madmax, Jan 4, 2013

    Having the same problem using 8.3.1 alpha 12967 . It goes in and out. I lose access to the share and get denied and come back. I can't always transfer files, it will freeze window explorer. Not using FreeNAS in a virtual environment. I am using windows 8 for the client. If I recall correctly I was using windows 8 before on 8.2 and didn't have this problem.

    Any suggestions on troubleshooting on trying to determine the specific problem? I will try with windows 7 and report back.
  5. Offline

    cyberjock Forum Guard Dog/Admin

    Member Since:
    Mar 25, 2012
    Messages:
    13,220
    Message Count:
    13,220
    Likes Received:
    674
    Trophy Points:
    113
    cyberjock, Jan 4, 2013

    How about you start with NOT using an alpha release? They can be riddled with tons of unidentified problems and there are lots of outstanding tickets for show-stoppers if you use alphas/betas.

    If you've used the latest release and then tried the alpha and its still no-go then you're somewhat on your own except to put in a ticket. I'm not expecting people with problems with Windows 8 to get "loved" for a few months at least. That is assuming the issue isn't with configuration and is actually some incompatibility.
  6. Offline

    madmax Newbie

    Member Since:
    Aug 31, 2012
    Messages:
    56
    Message Count:
    56
    Likes Received:
    2
    Trophy Points:
    8
    madmax, Jan 5, 2013


    I'm using 8.3.1 for support for data encryption, one of the reasons I initially tried nas4free and now have returned back to freenas, also it seems in the forum that people have had success with owncloud in freenas.

    I tried windows 7 and that worked for most part, no CIFS freezes or errors. Since i have not been happy with windows 8 b/c of compatibility and support problems for myself, this was the tipping point for me to go back to windows 7.
    But I tried one last effort and upgraded freenas 8.3.1 alpha to 12969 and trying use windows 8 again and for w/e reasons it works. I'm not sure why. I check the support ticket area quickly and i didn't see anything that pointed out to me that would fix this problem so idk if that was the reason for fixing my issues at least at the moment. Anyways the only problem I'm having now is firefly and iTunes not seeing my wav and aiff files. After some more effort probably open another thread and see if anyone could help.
Thread Status:
Not open for further replies.

Share This Page