Configure Static IP

Discussion in 'FreeNAS 4 N00bs' started by Lucas Rey, Aug 23, 2011.

Thread Status:
Not open for further replies.
  1. Lucas Rey Member

    Member Since:
    Jul 25, 2011
    Message Count:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Lucas Rey, Aug 23, 2011

    Hello all,
    my FreeNAS 8.0 works fine and with DHCP configuration I'm able to contact external site (for example the SMTP server from google).

    I need to setup now a static IP, so I configured add Interface with the following parameters:

    IPv4 Address
    re0 192.168.10.6/24
    Nameserver: 192.168.10.1
    Default route: 192.168.10.1

    The problem there is I cannot ping anymore any external site. However the DNS works because it resolve the address (like the below example).

    Code (text):
    1. nas# ping google.it
    2. PING google.it (209.85.148.103): 56 data bytes
    3. --- google.it ping statistics ---
    4. 1 packets transmitted, 0 packets received, 100.0% packet loss
    5.  
    6. nas# ping 209.85.148.103
    7. PING 209.85.148.103 (209.85.148.103): 56 data bytes
    8. --- 209.85.148.103 ping statistics ---
    9. 3 packets transmitted, 0 packets received, 100.0% packet loss

    Now the problem is, why with DHCP works, what I miss?
  2. ProtoSD Active Member

    Member Since:
    Jul 1, 2011
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Aug 23, 2011

    Hi Lucas,

    It could be the DNS still works because the address is in cache. With DHCP you get the DNS server automatically, did you try to manually add a DNS server? Maybe also enter your IP without the /24. I use a static IP address with no problem, but I manually entered all the info like DNS, mask, gateway. Try that and see if it works.
  3. Lucas Rey Member

    Member Since:
    Jul 25, 2011
    Message Count:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Lucas Rey, Aug 24, 2011

    One reply should be enough :D
    Btw, sure DHCP configured something that I miss, but how do you setup the DNS and the other stuff? I have (in v8.0) the following settings:

    [IMG]

    [IMG]

    And then the network Summary:
    [IMG]


    Did I miss something?
  4. ProtoSD Active Member

    Member Since:
    Jul 1, 2011
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Aug 24, 2011

    Hi Lucas,

    Sorry about the duplicate posts, sometimes that happens here to me here, I don't know why.

    Anyway, I usually setup the network with a static IP when I do my installation from the console. I've also looked through the GUI on beta-4 and cannot find where you enter DNS! I think you have found a bug, so NO you didn't miss anything... If you edit the settings from the console you can add the DNS servers there. Hope that helps!

    EDIT: Wait, I found it, on the left side bar Network -> Global Configuration
    You can put DNS in there. Kind of not where you'd expect to find it.
  5. Lucas Rey Member

    Member Since:
    Jul 25, 2011
    Message Count:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Lucas Rey, Aug 25, 2011

    Don't worry, I was just joking! ;)

    Well, I tried to setup DNS from consolle but without success, where did you setup the DNS on GUI? Maybe on "Domain" setting?

    Because as reported on my previous post I have only:
    - Hostname
    - Domain
    - Default Gateway
    - Name Server

    Mine Default Gateway is the same IP for DNS, it's an hardware firewall (also used as DHCP server).

    What are driving me crazy is that with DHCP it works fine!!!! :mad:
    And I'm coming from FreeNAS 0.7 where the static IP works without problem! So the issue is on FreeNAS 8.0....
  6. ProtoSD Active Member

    Member Since:
    Jul 1, 2011
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Aug 25, 2011

    Here's a screenshot:

    [IMG]
  7. Lucas Rey Member

    Member Since:
    Jul 25, 2011
    Message Count:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Lucas Rey, Aug 27, 2011

    After some tries I finally hit the goal.

    I forced my DHCP server to assign always the same IP based on MAC Address (probably useless, but just to be sure), then, on FreeNAS I configured an interface with DHCP disabled and with static IP plus name server as DNS.

    After that, the external site was still unreachable:
    Code (text):
    1. nas# ping google.it
    2. PING google.it (74.125.39.106): 56 data bytes
    3. ping: sendto: No route to host
    4. ping: sendto: No route to host
    But, since the problem is on the routes, I need to manually setup the Default route directly on console.
    Code (text):
    1. nas# route add default 192.168.10.1
    And then finally I can reach any external address
    Code (text):
    1. nas# ping google.it
    2. PING google.it (74.125.39.147): 56 data bytes
    3. 64 bytes from 74.125.39.147: icmp_seq=0 ttl=51 time=44.141 ms
    4. 64 bytes from 74.125.39.147: icmp_seq=1 ttl=51 time=44.124 ms
    Thanks for your tips protosd, you help me a lot ;)
  8. ProtoSD Active Member

    Member Since:
    Jul 1, 2011
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Aug 27, 2011

    No problem, you're welcome! It's really strange that the GUI or console config wizard doesn't work for you, but I'm glad something I said got it to work for you.
  9. Lucas Rey Member

    Member Since:
    Jul 25, 2011
    Message Count:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Lucas Rey, Aug 27, 2011

    Yes it's strange, btw, DNS setup works on GUI, but the problem was the routes, and I cannot setup it from GUI! ;)
Thread Status:
Not open for further replies.

Share This Page