Copy from FreeNAS via CIFS fails

Discussion in 'Bug Reporting' started by eltoro, Apr 26, 2012.

  1. Offline

    eltoro

    Member Since:
    Mar 17, 2012
    Messages:
    21
    Message Count:
    21
    Likes Received:
    0
    Trophy Points:
    0
    eltoro, Apr 26, 2012

    Hi,

    I have starting to experience some problems with my FreeNAS 8.0.4 Release. When copying files to my client computer running Windows 7 via CIFS I pretty often get "File descriptor" errors or "File not available". Restart of the NAS-box did not help and restart of the client did not work either. I have one auxillirary parameter saying smb max protokol is smb2..

    But when transferring via AFP to my Mac works. So it seems to have something to do with CIFS.

    Has anyone experianced this?

    I see the following message in the log:

    Apr 27 07:19:35 eltoro-storage kernel: pid 2857 (smbd), uid 0: exited on signal 6
    Apr 27 07:19:37 eltoro-storage kernel: pid 2858 (smbd), uid 0: exited on signal 6
    Apr 27 07:20:16 eltoro-storage kernel: pid 2859 (smbd), uid 0: exited on signal 6

    And this is from log.smbd

    [2012/04/27 07:19:37.475276, 1] smbd/server.c:272(cleanup_timeout_fn)
    Cleaning up brl and lock database after unclean shutdown
    [2012/04/27 07:19:45.619391, 1] smbd/service.c:1081(make_connection_snum)
    mini-sd (192.168.1.10) connect to service Blandat initially as user eltoro (uid=1001, gid=0) (pid 2859)
    [2012/04/27 07:19:45.694845, 1] smbd/service.c:1081(make_connection_snum)
    mini-sd (192.168.1.10) connect to service Media initially as user eltoro (uid=1001, gid=0) (pid 2859)
    [2012/04/27 07:20:16.152769, 0] lib/fault.c:51(fault_report)
    ===============================================================
    [2012/04/27 07:20:16.152817, 0] lib/fault.c:52(fault_report)
    INTERNAL ERROR: Signal 11 in pid 2859 (3.6.3)
    Please read the Trouble-Shooting section of the Samba3-HOWTO
    [2012/04/27 07:20:16.152828, 0] lib/fault.c:54(fault_report)

    From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
    [2012/04/27 07:20:16.152837, 0] lib/fault.c:55(fault_report)
    ===============================================================
    [2012/04/27 07:20:16.152846, 0] lib/util.c:1117(smb_panic)
    PANIC (pid 2859): internal error
    [2012/04/27 07:20:16.152899, 0] lib/util.c:1221(log_stack_trace)
    BACKTRACE: 0 stack frames:
    [2012/04/27 07:20:16.152953, 0] lib/fault.c:416(dump_core)
    dumping core in /var/log/samba/cores/smbd
    [2012/04/27 07:20:16.154093, 1] smbd/server.c:300(remove_child_pid)
    Scheduled cleanup of brl and lock database after unclean shutdown
    [2012/04/27 07:20:16.989122, 1] smbd/service.c:1081(make_connection_snum)
    mini-sd(192.168.1.10) connect to service Media initially as user eltoro (uid=1001, gid=0) (pid 2904)
    [2012/04/27 07:20:36.154129, 1] smbd/server.c:272(cleanup_timeout_fn)
    Cleaning up brl and lock database after unclean shutdown
    [2012/04/27 08:15:03.296345, 1] smbd/service.c:1081(make_connection_snum)
    mini-sd (192.168.1.10) connect to service Blandat initially as user eltoro (uid=1001, gid=0) (pid 2904)
  2. Offline

    ProtoSD FreeNAS Guru

    Member Since:
    Jul 1, 2011
    Messages:
    3,358
    Message Count:
    3,358
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Apr 26, 2012

    Hi Eltoro,

    I think you might have found a bug. I've used the max protocol=smb2 also and haven't seen this problem.
  3. Offline

    sjieke FreeNAS Aware

    Member Since:
    Jun 7, 2011
    Messages:
    117
    Message Count:
    117
    Likes Received:
    4
    Trophy Points:
    18
    sjieke, Apr 26, 2012

    I've also seen smbd crash on my server when using 'max protocol=smb2', but only when using a Windows7 client.
    Using a linux client doesn't crash the server. I think it is because only the Win7 clients are effectively using the SMB2 protocol, other clients still use the default protocol. Removing the auxiliary parameter solved the issue for me, so I'm pretty sure that that parameter causes the issue. I will try enabling SMB2 again when FreeNAS 8.2 is released and I have upgraded.
  4. Offline

    eltoro

    Member Since:
    Mar 17, 2012
    Messages:
    21
    Message Count:
    21
    Likes Received:
    0
    Trophy Points:
    0
    eltoro, Apr 27, 2012

    Ok, it probably has something to do with SMB2 since my Linux-box with XBMC never showed any errors reading the files either...I´ll disable SMB2 support instead :-(
  5. Offline

    eltoro

    Member Since:
    Mar 17, 2012
    Messages:
    21
    Message Count:
    21
    Likes Received:
    0
    Trophy Points:
    0
    eltoro, Apr 27, 2012

    Actually, I think I posted my question in the wrong category. My intention was to post it in the Sharing category. Sorry for that...
  6. Offline

    ProtoSD FreeNAS Guru

    Member Since:
    Jul 1, 2011
    Messages:
    3,358
    Message Count:
    3,358
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Apr 27, 2012

    You did post it in sharing, I moved it because it's more likely a bug. I also have Windows 7 and didn't have this happen. I just checked and I have it disabled at the moment because I was experimenting with some settings.

Share This Page