CPU Doesn't Support Long Mode

Discussion in 'Installation' started by derekvw, May 8, 2012.

  1. Offline

    derekvw

    Member Since:
    May 8, 2012
    Messages:
    10
    Message Count:
    10
    Likes Received:
    0
    Trophy Points:
    1
    derekvw, May 8, 2012

    I'm trying to install FreeNAS on an intel atom 2700 box and when I boot from my usb, I get a "CPU Doesn't Support Long Mode" error.

    What's the purpose of this error and what can I do about it?

    Thanks!
  2. Offline

    ProtoSD FreeNAS Guru

    Member Since:
    Jul 1, 2011
    Messages:
    3,359
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, May 8, 2012

    It's basically telling you your CPU isn't 64 bit. Try installing the 32-bit version of FreeNAS.
  3. Offline

    derekvw

    Member Since:
    May 8, 2012
    Messages:
    10
    Message Count:
    10
    Likes Received:
    0
    Trophy Points:
    1
    derekvw, May 8, 2012

    I thought so. The D2700 is a 64bit processor though. That's why I was confused.
  4. Offline

    ProtoSD FreeNAS Guru

    Member Since:
    Jul 1, 2011
    Messages:
    3,359
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, May 8, 2012

    That IS strange. Perhaps there's a setting in the BIOS that might help.
  5. Offline

    ProtoSD FreeNAS Guru

    Member Since:
    Jul 1, 2011
    Messages:
    3,359
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, May 8, 2012

    See if you can find a setting in the BIOS called "VT". I found a reference to it, but not sure what it is.
  6. Offline

    louisk FreeNAS Aware

    Member Since:
    Aug 10, 2011
    Messages:
    431
    Message Count:
    431
    Likes Received:
    2
    Trophy Points:
    18
    Occupation:
    Professional Nerd
    Location:
    Portland, OR area
    Home page:
    louisk, May 8, 2012

    VT is a set of instructions to allow certain aspects of virtualization to be executed by the hardware natively instead of emulated.
  7. Offline

    Joshua Parker Ruehlig FreeNAS Guru

    Member Since:
    Dec 5, 2011
    Messages:
    1,310
    Message Count:
    1,310
    Likes Received:
    46
    Trophy Points:
    48
    Location:
    Sacramento, California, United States
    Joshua Parker Ruehlig, May 8, 2012

    I know some d2700 boards need a bios update to enable 64bit support.

    I really wanted to get a D2700 board for a media PC till I saw all the problems people were getting with any OS other than Windows 7 32bit. The graphics (GMA 3650) drivers and bios' need some serious help...
  8. Offline

    derekvw

    Member Since:
    May 8, 2012
    Messages:
    10
    Message Count:
    10
    Likes Received:
    0
    Trophy Points:
    1
    derekvw, May 9, 2012

    I saw the same reference to VT...I couldn't find any mention to it in my BIOS.

    I'll also try to do the update on the BIOS and see how that goes.

    Thanks!

Share This Page