FreeNAS in virtual box

Discussion in 'Introductions' started by miamiheat, Jun 13, 2011.

Thread Status:
Not open for further replies.
  1. miamiheat New Member

    Member Since:
    Jun 13, 2011
    Message Count:
    1
    Likes Received:
    0
    Trophy Points:
    0
    miamiheat, Jun 13, 2011

    Hi Friends,

    I have installed freenas 8 in my virtual box and when I go to web ui I don't see any menu option for "Disk Management" where I can add the disk. What could be the probem? I am totally new to this so bare with me please.

    Thanks
  2. matthewowen01 New Member

    Member Since:
    May 27, 2011
    Message Count:
    566
    Likes Received:
    3
    Trophy Points:
    0
    matthewowen01, Jun 13, 2011

    did you add disks to your virtual machine for FreeNAS to find?
  3. BradChesney79 New Member

    Member Since:
    Jun 14, 2011
    Message Count:
    3
    Likes Received:
    0
    Trophy Points:
    0
    BradChesney79, Jun 14, 2011

    FreeNAS seems to need at least two disks for the GUI to work as intended. I managed to have the opposite problem. I added disks and created a way to mount my volume wrong which ended up storing files on my OS drive.

    for you:

    create a miniscule .vmdk or .vdi in the VM manager
    add it to your machine in the settings

    In FreeNAS

    Access the command line

    mkdir /mnt/mountpoint

    Get into the FreeNAs GUI

    Add the other disk from earlier and mount it at /mnt/mountpoint


    Boom! Now you are writing to the OS Disk. Mind your permissions.

    For me it was a glitch, for you it could be a workaround.
Thread Status:
Not open for further replies.

Share This Page