How to set up a static ip for FreeNAS GUI

Discussion in 'New to FreeNAS?' started by Fabbat, Oct 24, 2013.

  1. Offline

    Fabbat Newbie

    Member Since:
    Oct 24, 2013
    Messages:
    31
    Message Count:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rome, IT
    Fabbat, Oct 24, 2013

    Hi all,
    I'm new of this exciting forum. I'm new of FreeNAS too. I set up FreeNas and now I love it! My problem is that I want to reach the Administrative GUI by specific IP, out of DHCP range. I tried using Interface definition but my plugins stop to work, and in the documentation I read that the GUI is not included in the Interface option ( this my understood, sorry...)
    Can someone help me hot to set up proprerly FreeNAS to reach with static IP the GUI with no effect on other plugin (Plex, Transmission, OwnCloud)?
    I tryed to serch in this forum with words "static,IP,config" but I didn't find a clear answer to my question.
    I have Freenas 9.1.1, a Intel Core2 Duo CPU, 2 MB of RAM and 2TB of HDD (yes it's a cheap NAS!)
    Thank you all
  2. Offline

    pirateghost Unintelligible Geek

    Member Since:
    Feb 29, 2012
    Messages:
    1,019
    Message Count:
    1,019
    Likes Received:
    40
    Trophy Points:
    48
    Occupation:
    Instrumentation Engineer
    Location:
    Moore, OK
    pirateghost, Oct 24, 2013

    From the console there is an option to configure IP address. Set the static ip there.
  3. Offline

    Fabbat Newbie

    Member Since:
    Oct 24, 2013
    Messages:
    31
    Message Count:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rome, IT
    Fabbat, Oct 24, 2013

    Pirategost, thank you for your replay. I'm not shure about what is the console. Do you refer to the web administration GUI? I was looking at Network -> Global config, but I cannot find the right option to configure the static ip. Please, could you tell me the full path to find the appropriate option?
    Thank you
  4. Offline

    Mr_N Newbie

    Member Since:
    Aug 31, 2013
    Messages:
    57
    Message Count:
    57
    Likes Received:
    2
    Trophy Points:
    8
    Mr_N, Oct 24, 2013

    No the local console which your presented with right after you finish the freenas install, at which time you set the ip on your network interface and then all future interaction can be via the web gui which you reach by putting said static ip into your web browser etc
  5. Offline

    pirateghost Unintelligible Geek

    Member Since:
    Feb 29, 2012
    Messages:
    1,019
    Message Count:
    1,019
    Likes Received:
    40
    Trophy Points:
    48
    Occupation:
    Instrumentation Engineer
    Location:
    Moore, OK
    pirateghost, Oct 24, 2013



    This.
  6. Offline

    Fabbat Newbie

    Member Since:
    Oct 24, 2013
    Messages:
    31
    Message Count:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rome, IT
    Fabbat, Oct 24, 2013

    Ok, thank you all. Just last question, if I change now the option in the console, this could affect some other functionality or setting (for instance: plugins stop to work,...)?
  7. Offline

    pirateghost Unintelligible Geek

    Member Since:
    Feb 29, 2012
    Messages:
    1,019
    Message Count:
    1,019
    Likes Received:
    40
    Trophy Points:
    48
    Occupation:
    Instrumentation Engineer
    Location:
    Moore, OK
    pirateghost, Oct 24, 2013

    The IP of the freenas machine should have no bearing on plugins since they run on their own ip addresses

    Sent from my Nexus 7
  8. Offline

    Fabbat Newbie

    Member Since:
    Oct 24, 2013
    Messages:
    31
    Message Count:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rome, IT
    Fabbat, Oct 31, 2013

    Thank you all. I tried to use console during these days. I choose option 1, the result was I added a new interface settings for the re0 interface. The IP address now is correct but my plugins stop to work, if I cancel this interface definition (also via webGUI) and I re-use the DHCP service, plugins start to work.
    Maybe I use the wrong voice of console. COuld someone tell me which option number I will use to set up the static IP of my freeNAS?

    Thank you
  9. Offline

    pirateghost Unintelligible Geek

    Member Since:
    Feb 29, 2012
    Messages:
    1,019
    Message Count:
    1,019
    Likes Received:
    40
    Trophy Points:
    48
    Occupation:
    Instrumentation Engineer
    Location:
    Moore, OK
    pirateghost, Oct 31, 2013

    how about you troubleshoot why your plugins would stop working? it sounds like you dont really have a grasp on basic networking.

    option 1 was the correct option on the console. Configure your static IP. Beyond that, within the webGUI, you need to make sure you have 'NAMESERVERS' configured, as well as a 'DEFAULT GATEWAY'. These are basic networking concepts for your computer to have network access. Every computer must have a. IP address, b. default gateway, c. subnet mask, d. nameserver(s); that is, if you expect any of the services on that computer to be able to communicate with anything but itself.
  10. Offline

    Fabbat Newbie

    Member Since:
    Oct 24, 2013
    Messages:
    31
    Message Count:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rome, IT
    Fabbat, Nov 1, 2013


    About my knoledge maybe you right, anyway thank you for your response. I try to give more details on my problem. I create an interface for re0 as you can see in the picture "interface Freenas.jpg"

    Everything works well, but not the plugin section. As you can see in the picture "freenas plugin error" I cannot see the plugin. The configuration tab with collection URL field is properly filled in with "http://www.appcafe.org/freenas/json" address.

    did I forget something in the interface set up to fix, or I missed some parameters?

    Attached Files:

  11. Offline

    pirateghost Unintelligible Geek

    Member Since:
    Feb 29, 2012
    Messages:
    1,019
    Message Count:
    1,019
    Likes Received:
    40
    Trophy Points:
    48
    Occupation:
    Instrumentation Engineer
    Location:
    Moore, OK
    pirateghost, Nov 1, 2013

    Fabbat likes this.
  12. Offline

    Fabbat Newbie

    Member Since:
    Oct 24, 2013
    Messages:
    31
    Message Count:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rome, IT
    Fabbat, Nov 1, 2013


    Thank you, finally I understood where put parameters and I fixed the problem. Thanks again for your patience :)
  13. Offline

    Jazzman

    Member Since:
    Jul 13, 2014
    Messages:
    1
    Message Count:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Jazzman, Jul 20, 2014

    Almost a year later and this post helped me :), thank you Fabbat!

Share This Page