How to Setup Freenas with Xbox 360

Discussion in 'FreeNAS 4 N00bs' started by RedNovember, Jul 23, 2011.

  1. RedNovember New Member

    Member Since:
    Jul 23, 2011
    Message Count:
    3
    Likes Received:
    0
    Trophy Points:
    0
    RedNovember, Jul 23, 2011

    I start up my Xbox 360 and browse to my freenas server but it won't open my videos/pictures. How do I setup freenas to communicate/stream content to the Xbox 360? ;)
  2. ProtoSD Active Member

    Member Since:
    Jul 1, 2011
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Jul 23, 2011

    Can you tell us what version of FreeNAS you are using? This forum is for version 8.x, and there's a link at the top of this page if you are using version .7

    FreeNAS 8.x doesn't have any media streaming features (yet), that's why I suspect you either have version .7 or were not aware that 8.x doesn't have that feature yet (version 8.1 will, but not for a long while).

    So please tell us which version you have and someone will try to help you more.
  3. RedNovember New Member

    Member Since:
    Jul 23, 2011
    Message Count:
    3
    Likes Received:
    0
    Trophy Points:
    0
    RedNovember, Jul 23, 2011

    thanks man for the reply

    OS Version: FreeBSD 8.2-RELEASE-p1

    I played around with Windows Shares/FTP/CIFS but not much came out of that. The xbox will find the server no problem but it won't connect/browse through my folders. Any help would be appreciated.
  4. ProtoSD Active Member

    Member Since:
    Jul 1, 2011
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Jul 23, 2011

    It sounds like it could be your permissions. You could try opening up your permissions and see if that helps and then you can adjust things from there.

    If you go to Storage -> Volumes (on the sidebar / left side of GUI), then below the name of your volume you should see 'Change Permissions'.

    Click on that and a window will popup and you'll see an area that says 'Mode:' select all of the checkboxs for Read/Write/Execute and for Owner/Group/Other.

    Then click on the checkbox at the bottom that says 'Set Permission Recursively'
    Then click on the 'Change' button

    You might have to wait a few minutes if you have a lot of files, but after that give your Xbox another try.

    Hope that helps, if not report back and we'll see if there's something else.

    I don't have an Xbox, so I'm just trying to give you some general pointers.
  5. RedNovember New Member

    Member Since:
    Jul 23, 2011
    Message Count:
    3
    Likes Received:
    0
    Trophy Points:
    0
    RedNovember, Jul 25, 2011

    alright I changed the permissions for the storage volume but the problem remains. Is there a certain service that should be on and running?
  6. ProtoSD Active Member

    Member Since:
    Jul 1, 2011
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Jul 25, 2011

    The CIFS service should be on, but it would be odd that you were able to browse and see FreeNAS if that were off. I'll give it some more thought and update.

Share This Page