hwpstate0: set freq failed, err 6

Discussion in 'Bug Reporting' started by darkryoushii, Feb 25, 2013.

  1. Offline

    darkryoushii Newbie

    Member Since:
    Jan 23, 2013
    Messages:
    49
    Message Count:
    49
    Likes Received:
    0
    Trophy Points:
    6
    darkryoushii, Feb 25, 2013

    Hey,

    I recently enabled powerd in FreeNAS 8.3.1 RC1 and started getting the following messages in console footer (trinity is my NAS name):
    Code (text):
    1. Feb 25 23:15:44 trinity kernel: hwpstate0: set freq failed, err 6
    2. Feb 25 23:16:15 trinity last message repeated 9 times
    3. Feb 25 23:17:42 trinity last message repeated 14 times
    The server is running an AMD A6-5400K with the rest of the specifications in my signature.

    I have found this patch http://lists.freebsd.org/pipermail/freebsd-stable/2012-May/067758.html though I have been unable to test it as I don't have the know-how to build it and implement it.

    I really would hope that this can be fixed fairly quickly, as my power usage is 5x higher without it being able to idle at low frequencies.

    Any help would be greatly appreciated,
    DarkRyoushii
  2. Offline

    joeschmuck Old Man

    Member Since:
    May 28, 2011
    Messages:
    2,611
    Message Count:
    2,611
    Likes Received:
    86
    Trophy Points:
    48
    Occupation:
    Electrical Engineer, Data Analysis, and Management
    Location:
    Virginia
    joeschmuck, Feb 28, 2013

    Was this present on a previous version of FreeNAS? It would help for continuity.
  3. Offline

    Schwinni

    Member Since:
    Apr 19, 2013
    Messages:
    10
    Message Count:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Schwinni, May 2, 2013

    I have the same message with my A4-5300. It seems to affect all AMD CPUs with Turbo. Frequency scaling still works though.
    Until the suggested patch makes it into the FreeBSD kernel I wanted to use a setting to avoid the spamming of my log: http://forums.freebsd.org/archive/index.php/t-11356.html
    Unfortunately /boot/loader.conf is read only. How can I edit this file?
  4. Offline

    PowerWiesel

    Member Since:
    Feb 19, 2014
    Messages:
    13
    Message Count:
    13
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Deutschland
    PowerWiesel, Mar 29, 2014

    (if it still wants someone to know)


    i tried
    in /boot/loader.conf, but it does not seem to make a difference for me.

    still freenas kernel: hwpstate0: set freq failed, err 6

    AMD FX(tm)-4300 Quad-Core Processor (turbo disabled) on SABERTOOTH 990FX R2.0

    Does anyone have an idea in the meanwhile ?
  5. Offline

    cyberjock Forum Guard Dog/Admin

    Member Since:
    Mar 25, 2012
    Messages:
    13,630
    Message Count:
    13,630
    Likes Received:
    704
    Trophy Points:
    113
    cyberjock, Mar 29, 2014

    Yes, stop using AMD just like the post above yours says. ;)

    Sorry but using AMD means you are in a small island with a small number of people. As such, you're almost on your own to solve the problems. :(
  6. Offline

    diedrichg FreeNAS Aware

    Member Since:
    Dec 4, 2012
    Messages:
    259
    Message Count:
    259
    Likes Received:
    11
    Trophy Points:
    18
    diedrichg, Mar 29, 2014

    SOLVED?: I too was getting this exact error after upgrading to 9.2.x, this did not occur in 9.1.x or previous versions. Various Google searches did not help until I read Schwinni's comment about Turbo. I decided to Google Turbo. The gist was to disable Turbo mode and Cool n Quiet in the UEFI. I did just that and after reboot I have yet to have a single error after 30 minutes so far! I made a few other settings changes too which may be overkill but here's what I did:
    • Overclock Mode
      • Manual - 100MHz
    • AMD Turbo Core
      • Disabled
    • Advanced > CPU Config
      • Cool n Quiet
        • Disabled
      • SVM(virtualization)
        • Disabled
    fwiw: Yes, I know I have improper hardware running my home server. I didn't know better when I started. I do now, but I don't have $600 right now to buy a Xeon processor, Supermicro mobo and ECC RAM.

    Here's my processor and motherboard for reference:
    AMD A6-5400K Trinity 3.6GHz (3.8GHz Turbo) Socket FM2 65W Dual-Core
    ASRock FM2A85X-ITX FM2 AMD A85X (Hudson D4)
  7. Offline

    diedrichg FreeNAS Aware

    Member Since:
    Dec 4, 2012
    Messages:
    259
    Message Count:
    259
    Likes Received:
    11
    Trophy Points:
    18
    diedrichg, Mar 30, 2014

    For me, no. Everything was fine up until 9.2.1.3. (I can't seem to remember if it was present in 9.2.1.2 or 9.2.1.1 since these releases were so close.)
  8. Offline

    TheSmoker FreeNAS Aware

    Member Since:
    Sep 19, 2012
    Messages:
    211
    Message Count:
    211
    Likes Received:
    7
    Trophy Points:
    18
    TheSmoker, Mar 31, 2014

    Do the following. Enable turbo and all power saving features in bios. That will do a better job than powerd. Then, disable powerd. Done. Solved. And it will save power as well. Without powerd. Cheers!

Share This Page