SOLVED Mounting Failed with Error 19

Discussion in 'Installation' started by Savell Martin, Jul 4, 2013.

  1. Offline

    James Snell

    Member Since:
    Jul 25, 2013
    Messages:
    29
    Message Count:
    29
    Likes Received:
    6
    Trophy Points:
    3
    Occupation:
    Mage of Engineering
    Location:
    Calgary, Alberta, Canada
    James Snell, Nov 2, 2013

    I had the same issue with my ASUS B85M-G (bios version 0604).
    It works for me with:
    Intel xHCI Mode = Disabled
    EHCI Hand-off = Disabled

    I'll add that my integrated NIC (Realtek 8111G is not supported by FreeNAS 9.1.1 - I was sure I read somewhere that it should work. Looks like I get to go learn about how to install the driver manually.. "Yay".)

    EDIT: If anyone finds this comment on account of the Realtek 8111G on FreeNAS 9.1.1, my little micro-guide explaining how to get it working is located here.
  2. Offline

    JimPhreak FreeNAS Aware

    Member Since:
    Sep 28, 2013
    Messages:
    132
    Message Count:
    132
    Likes Received:
    0
    Trophy Points:
    16
    JimPhreak, Nov 7, 2013

    Got this error today after doing a reboot. Server has been up and running for a week+ but this is the first time I rebooted it since a lot of changes were made.

    System is:

    SuperMicro X10SLM-F-O board
    Haswell i3-4130 CPU

    I will try disabling xHCI mode when I get home after work.
  3. Offline

    DrKK NAS-ty with the FreeNAS

    Member Since:
    Oct 15, 2013
    Messages:
    484
    Message Count:
    484
    Likes Received:
    49
    Trophy Points:
    28
    Occupation:
    C Programmer
    Location:
    Baltimore
    DrKK, Nov 7, 2013

    That's my board. Let me know if it works, please. I just gave up rebooting warm, and just do cold restarts, usually without problems.
  4. Offline

    JimPhreak FreeNAS Aware

    Member Since:
    Sep 28, 2013
    Messages:
    132
    Message Count:
    132
    Likes Received:
    0
    Trophy Points:
    16
    JimPhreak, Nov 8, 2013

    Mine works fine with xHCI mode disabled in the BIOS. I also have my USB boot drive plugged into the USB 3.0 port on the motherboard.
  5. Offline

    robotmonkeys

    Member Since:
    Nov 9, 2013
    Messages:
    13
    Message Count:
    13
    Likes Received:
    1
    Trophy Points:
    3
    robotmonkeys, Nov 9, 2013

    Disabling xHCI and EHCI, and turning off slow boot didn't work for me with FreeNas 9.1.1 . I had to also downgrade to 8.3.2 in order to get mine to boot of the USB stick.

    My motherboard is an Asus H871-plus. A bit of a bummer, because I bought this MB specifically for it's USB3 support. *grrrr* *sniff*
  6. Offline

    Dusan FreeNAS Guru

    Member Since:
    Jan 29, 2013
    Messages:
    1,165
    Message Count:
    1,165
    Likes Received:
    203
    Trophy Points:
    63
    Occupation:
    PHB
    Location:
    Bratislava, Slovakia
    Dusan, Nov 9, 2013

  7. Offline

    robotmonkeys

    Member Since:
    Nov 9, 2013
    Messages:
    13
    Message Count:
    13
    Likes Received:
    1
    Trophy Points:
    3
    robotmonkeys, Nov 10, 2013

  8. Offline

    panz NAS-ty with the FreeNAS

    Member Since:
    May 24, 2013
    Messages:
    435
    Message Count:
    435
    Likes Received:
    27
    Trophy Points:
    28
    panz, Nov 11, 2013

    Sometimes choosing "reload UEFI defaults" or similar entry of the BIOS menu, fixes a lot of things. This UEFI stuff is going to make me crazy :)
  9. Offline

    Michael Wulff Nielsen FreeNAS Aware

    Member Since:
    Oct 3, 2013
    Messages:
    182
    Message Count:
    182
    Likes Received:
    8
    Trophy Points:
    18
    Michael Wulff Nielsen, Dec 3, 2013

    I can confirm the turning of xHCI in both the USB and PCH-IO settings does the trick on my Asus P9D-M.
  10. Offline

    Kenny3

    Member Since:
    Dec 10, 2013
    Messages:
    9
    Message Count:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Kenny3, Dec 10, 2013

    Had the same mountroot> problem with FreeNAS-9.1.1-RELEASE-x64 (a752d35). Couldn't find xHCI option in the BIOS, but disabling all USB3.0 settings seemed to do the trick.

    Haswell Intel I3-4130T 2.90 (LGA 1150)
    ASRock E3C226D2I, Mini ITX
    4x WD Red 3 TB
    16GB Basic Kingston ECC RAM CL9
  11. Offline

    Quicksand Jesus

    Member Since:
    Aug 31, 2013
    Messages:
    7
    Message Count:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Quicksand Jesus, Dec 10, 2013

    Why is this marked with solved? I'm still on the old version, waiting for an update to Freenas which will support USB 3.0. Is there any news out there?
  12. Offline

    Dusan FreeNAS Guru

    Member Since:
    Jan 29, 2013
    Messages:
    1,165
    Message Count:
    1,165
    Likes Received:
    203
    Trophy Points:
    63
    Occupation:
    PHB
    Location:
    Bratislava, Slovakia
    Dusan, Dec 10, 2013

    In 9.2.0 USB3 will be disabled by default again, so if you area able to boot 8.3.1, you should be able to boot 9.2.0 too. If you want to try it, the release candidate is here: http://iso.cdn.freenas.org/9.2.0/RC/
  13. Offline

    Quicksand Jesus

    Member Since:
    Aug 31, 2013
    Messages:
    7
    Message Count:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Quicksand Jesus, Dec 11, 2013

    Thanks!! I'll give it a try this weekend.
  14. Offline

    Jeremy Stewart

    Member Since:
    Dec 18, 2013
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Jeremy Stewart, Dec 18, 2013

    I have this same problem with no USB 3 ports on the system.
    End up with an error 19, and drops to a mountroot prompt. I'm using the CD installer to a hard drive, and everything installs perfectly. On the reboot, I get squat.
    I'm using an HP DC 5700... no options to disable anything in the BIOS, pretty basic.
    Any thoughts?

    (Someone needs to unmark this as solved... I haven't seen any solutions in this thread, just avoidance and hardware specific thoughts.)
  15. Offline

    Jeremy Stewart

    Member Since:
    Dec 18, 2013
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Jeremy Stewart, Dec 19, 2013

    Looks like in my case it was the fact the installer preferred ada1 instead of ada0 (even though it installed fine on ada0). Going back to 8.3.1, the installer defaults to ada1, but not the case in 9.1+.
    Not a fix, not solved, just a revelation.
  16. Offline

    cyberjock Forum Guard Dog/Admin

    Member Since:
    Mar 25, 2012
    Messages:
    12,407
    Message Count:
    12,407
    Likes Received:
    618
    Trophy Points:
    113
    cyberjock, Dec 19, 2013

    The issue is marked as solved as the solution is to disable USB3. The issue is that USB3 support for some chips is not fully compatible with the hardware. If your motherboard won't let you disable USB3 you maybe able to get aroundit by booting from a USB2.0 port. Other than that, you can try using the 9.2.0 nightly build(USB3 drivers are disabled by default so this problem will go away for many) or try 8.3.1(USB3 drivers were disabled by default).
  17. Offline

    Jeremy Stewart

    Member Since:
    Dec 18, 2013
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Jeremy Stewart, Dec 19, 2013

    This computer as mentioned, does not have USB 3 ports. As of 9.2 RC, USB3 was disabled by default (which I also tested). In either case I still got the mountroot error 19.
    So while 9.2 RC will contain a fix and "solve" those who had issues related to USB3, it does not prevent some error 19's from happening that are not related to USB3. My case in point. I got the error by FreeNAS defaulting the installation to ada0 instead of ada1. Why it makes a difference, who knows... but when you stop seeing error 19 when trying to run a default installation, then the issue is solved.
  18. Offline

    cyberjock Forum Guard Dog/Admin

    Member Since:
    Mar 25, 2012
    Messages:
    12,407
    Message Count:
    12,407
    Likes Received:
    618
    Trophy Points:
    113
    cyberjock, Dec 19, 2013

    You do realize that error 19 can be caused by about 1000 different things. Up to and including your motherboard not being properly supported under FreeBSD? We get many people with hardware that doesn't run FreeBSD. Most commonly it's certain Dell and HP servers. And if your hardware is http://h10010.www1.hp.com/wwpc/ca/e...2132884-12132884-12132884-12736054.html?dnr=2 then I wouldn't expect it to be compatible.

    So I disagree.
  19. Offline

    Jeremy Stewart

    Member Since:
    Dec 18, 2013
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Jeremy Stewart, Dec 19, 2013

    The 5700 & 5800 works just fine installing on ada0 as mentioned. FreeNAS used to be (many years ago) a project that would repurpose a decommissioned computer into a decent NAS. Something change here? I certainly wouldn't consider repurposing a new unit into a NAS... that's what off the shelf NAS's are for.

    Anyhow, don't want to start a flame war here. If you say that error 19 can be caused by 1000 different things, then we are both at a disagreement on what's solved and not. How about a sticky? At the very least, I pointed out a potential bug fix.
  20. Offline

    cyberjock Forum Guard Dog/Admin

    Member Since:
    Mar 25, 2012
    Messages:
    12,407
    Message Count:
    12,407
    Likes Received:
    618
    Trophy Points:
    113
    cyberjock, Dec 19, 2013

    FreeNAS was until it was sold to iXsystems. At that point the project was wiped clean and redone from the ground up. The old FreeNAS was renamed to NAS4Free. You are welcome to go to their website and try their product. It's not likely to work any better for you, but you are welcome to try it.

    If you read the FreeNAS manual and the stickies that volunteers like myself have written we have significant system requirements. 8GB of RAM, ECC RAM, server grade parts, etc. Re-purposing old hardware for a FreeNAS server isn't going to happen as most people don't have spare server grade parts. This is just a fact of life. You can absolutely break every rule we have if you want. But, based on forum experience it is likely to end badly for you and your data if you do that.

    This thread was born because as FreeNAS 9.1 hit the market and Haswell hit the market it was identified that Haswell hardware isn't compatible with FreeBSD 9.1 since Haswell hit the market just 3 months ago. We had a huge number of users with Error 19 when Haswell hit which is what created this thread. If you search around you'll find we have threads created here and there since 2011 that have had error 19s. Some fixed with BIOS updates, disabling some hardware, etc. Some people just never got it to work and either went to a different OS or bought newer/different hardware.

    But if you look up your hardware it says its a desktop. That means there's virtually no chance HP tested that hardware for FreeBSD. That being said, there's a good chance it wouldn't run FreeBSD if you tried it just based on that info. Not surprisingly, you tried it and it didn't work. To me, you are another person that has some hardware you are trying to reuse, but this is not the OS you are looking for. You aren't the first one to find out that you shouldn't repurpose a desktop to a server with FreeNAS. And I have no doubt you won't even be the last one today. Just drop into our IRC as we get several a day.

Share This Page