Network Jail IP not available

Discussion in 'Plugins' started by cyberjock, Jul 21, 2012.

  1. Offline

    cyberjock Forum Guard Dog/Admin

    Member Since:
    Mar 25, 2012
    Messages:
    12,369
    Message Count:
    12,369
    Likes Received:
    617
    Trophy Points:
    113
    cyberjock, Jul 21, 2012

    So I've upgraded to 8.2-RELEASE-p1 in my virtual machine and I've started playing with the jail. I've setup the jail and I have successfully logged into the jail. I get the alert that the IP address for the jail is unreachable so the plugs will not work.

    So I logged into the jail (jexec 1 csh) and I cannot ping my router. I then logged out of the jail and tried to ping the jail IP. It was not reachable. I am sure my subnet is correct (255.255.255.0). I have tried adding plugins but I just get more errors relating to the fact that the jail IP cannot be found. Right now I have no plugins installed yet. I figured troubleshooting would be easier with just the jail installed.

    Here's some other odd things that MAY help identify the issue. I haven't been able to resolve these quirks.

    1. I have noticed that I cannot access the NTP servers that are defaulted in FreeNAS. I added the one that is somewhat local to me (Chicago, IL) but I still have to "force" it because I get an error that the NTP cannot be contacted. Of course, if I were to ping www.google.com it works perfectly. I do not know if NTP servers are being blocked by a firewall(my router, my symantec antivirus on the host OS has the firewall disabled at the moment for other unrelated reasons) or if there is something wrong with the NTP service in FreeNAS because it is a guest OS in a VMWare virtual machine. I seem to remember there used to be weird things that would go on when a guest machine tried to change the time or date because the guest time/date is supposed to be in sync with the host OS.

    2. My network(in particular, my router) does not support IPv6. I've disabled the service on all of my my workstations and the machines that FreeNAS runs as a guest on. Yet, when I bootup after I installed the jail I get these errors in the log at the bottom of the UI....

    FreeNAS kernel: bridge0: Ethernet address: 76:77:11:ab:e4:24
    FreeNAS kernel: epair0a: Ethernet address: 02:20:82:00:04:0a
    FreeNAS kernel: epair0b: Ethernet address: 02:20:82:00:05:0b
    FreeNAS kernel: epair0a: link state changed to UP
    FreeNAS kernel: epair0b: link state changed to UP
    FreeNAS kernel: epair0a: promiscuous mode enabled
    FreeNAS kernel: em0: promiscuous mode enabled
    FreeNAS kernel: epair0b: DAD detected duplicate IPv6 addres fe80:2::20:82ff:fe00:50b: NS in/out=1/1, NA in=0
    FreeNAS kernel: epair0b: DAD complete for fe80:2::20:82ff:fe00:50b - duplicate found
    FreeNAS kernel: epair0b: manual intervention required
    FreeNAS kernel: epair0b: possible hardware address duplication detected, disable IPv6
    FreeNAS ntpd[1564]: time reset +9.314228 s

    Keep in mind my FreeNAS server uses DHCP for it's address, but it is setup as a static IP in my router DHCP settings. I'm also confused because IPv6 isn't supported in the jail from what I've read but an error(shown below) says to disable IPv6.

    So can anyone tell me what I am doing wrong? Here's the ifconfig for my FreeNAS server:

    Code (text):
    1.  
    2. em0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    3.         options=98<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
    4.         ether 00:0c:29:12:78:8f
    5.         inet 192.168.0.99 netmask 0xffffff00 broadcast 192.168.0.255
    6.         media: Ethernet autoselect (1000baseT <full-duplex>)
    7.         status: active
    8. lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    9.         options=3<RXCSUM,TXCSUM>
    10.         inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
    11.         inet6 ::1 prefixlen 128
    12.         inet 127.0.0.1 netmask 0xff000000
    13.         nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
    14. bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    15.         ether 06:d8:58:7a:ff:26
    16.         id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    17.         maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
    18.         root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
    19.         member: em0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
    20.                 ifmaxaddr 0 port 1 priority 128 path cost 20000
    21.         member: epair0a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
    22.                 ifmaxaddr 0 port 4 priority 128 path cost 2000
    23. epair0a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    24.         ether 02:08:d8:00:04:0a
    25.         media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
    26.         status: active
    27.  
    Here's the ifconfig for my jail:

    Code (text):
    1.  
    2. lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384              
    3.         options=3<RXCSUM,TXCSUM>                                                
    4.         inet 127.0.0.1 netmask 0xff000000                                      
    5.         inet6 ::1 prefixlen 128                                                
    6.         inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1                              
    7.         nd6 options=3<PERFORMNUD,ACCEPT_RTADV>                                  
    8. epair0b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500  
    9.         ether 02:08:d8:00:05:0b                                                
    10.         inet 192.168.0.98 netmask 0xffffff00 broadcast 192.168.0.255            
    11.         inet6 fe80::8:d8ff:fe00:50b%epair0b prefixlen 64 duplicated scopeid 0x2
    12.         nd6 options=b<PERFORMNUD,ACCEPT_RTADV,IFDISABLED>                      
    13.         media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)                    
    14.         status: active  
    15.  
    Any ideas? I've been scratching my head at this for 18 hours, watched a youtube video from protosd, read the manual for the applicable sections, and searched the forum for other people with similar situations. No help at all :(

    On another note.. maybe we should add a section of the FreeNAS Help and support forum for Jail and plugin issues. I really wasn't sure where I should put my issue, so I figured I'd try here.
  2. Offline

    cyberjock Forum Guard Dog/Admin

    Member Since:
    Mar 25, 2012
    Messages:
    12,369
    Message Count:
    12,369
    Likes Received:
    617
    Trophy Points:
    113
    cyberjock, Jul 21, 2012

    I think I'm about to feel stupid.. was there a Plugin section already?
  3. Offline

    cyberjock Forum Guard Dog/Admin

    Member Since:
    Mar 25, 2012
    Messages:
    12,369
    Message Count:
    12,369
    Likes Received:
    617
    Trophy Points:
    113
    cyberjock, Jul 21, 2012

    I just took a nap since I was so exhausted from being up so long. I found out that when I disabled the Symantec Antivirus firewall the Windows Server 2008 R2 built-in firewall enabled. As soon as I disabled that and rebooted FreeNAS everything started working correctly. Grr.
  4. Offline

    skunkworx

    Member Since:
    Nov 30, 2012
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    0
    skunkworx, Nov 30, 2012

    I have been trying to set up FreeNas 8.3 in VMware player 5 to see if it fits my needs before I invest in getting some dedicated hardware to run it on.

    However when I install the Jail and the MiniDNLA pluging I get the same problem with the "Network Jail IP not available" message. I have checked my ifconfig inside and outside the Jail. Outside the jail I have the ip address of 192.168.1.200 that I configured as static IP. Inside the Jail I get the ip adress of 127.0.0.1 reported but when installing the Jail I gave it an IP of 192.168.1.201.

    I have tried to disable my firewall (Comodo) on my host machine but that hasn't made any difference.

    Does anyone have any further suggestions as to what might be wrong?
  5. Offline

    William Grzybowski FreeNAS Guru

    Member Since:
    May 27, 2011
    Messages:
    1,659
    Message Count:
    1,659
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    Curitiba, Brazil
    William Grzybowski, Nov 30, 2012

    Enable promiscuous mode in vmware network settings.
  6. Offline

    skunkworx

    Member Since:
    Nov 30, 2012
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    0
    skunkworx, Nov 30, 2012

    I am using vmware player 5 and I can't see any promiscuous mode on the network settings. I did a bit of research and found that I could add a setting ethernet0.noPromisc = "FALSE" to the vmx file but this didn't make any difference.

    Anyone with any other ideas?
  7. Offline

    clint.mcguire

    Member Since:
    Dec 9, 2012
    Messages:
    1
    Message Count:
    1
    Likes Received:
    0
    Trophy Points:
    0
    clint.mcguire, Dec 9, 2012

    Setting Promiscuous mode on the vSwtich to "accept" resolved the issue for me.
    It should probably be added to the documentation...
  8. Offline

    skunkworx

    Member Since:
    Nov 30, 2012
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    0
    skunkworx, Dec 10, 2012

    I ended up using virtual box and this worked without any modification to the setp.
  9. Offline

    William Grzybowski FreeNAS Guru

    Member Since:
    May 27, 2011
    Messages:
    1,659
    Message Count:
    1,659
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    Curitiba, Brazil
    William Grzybowski, Dec 10, 2012

    Feel free, its a wiki.

Share This Page