NFS mount failed RPCPROG_MNT: RPC: Timed out

Discussion in 'Sharing' started by bforest, Feb 3, 2012.

  1. bforest New Member

    Member Since:
    Jun 18, 2011
    Message Count:
    8
    Likes Received:
    0
    Trophy Points:
    0
    bforest, Feb 3, 2012

    Hello All,

    Any assistance will be greatly appreciated!

    I am attempting to mount an NFS share from a PCBSD workstation. [FYI, I have worked on this problem for some time and tried many different things but for simplicity, Here is basically what is happening and I will follow any direction you suggest.

    FreeNAS NFS share configuration attached: Screenshot-02032012-08:16:30.jpg

    Code (text):
    1. [PCUser@ws5] ~/Desktop> su - root
    2. Password:
    3. [root@ws5] ~# ls -la /mnt
    4. total 16
    5. drwxr-xr-x   4 root  wheel   512 Jan 30 08:35 .
    6. drwxr-xr-x  21 root  wheel  1024 Feb  2 23:31 ..
    7. drwxr-xr-x   2 root  wheel   512 Jan 30 08:34 nas1
    8. drwxr-xr-x   2 root  wheel   512 Jan 30 08:34 nas2
    9. [root@ws5] ~# cat /etc/fstab
    10. # Device        Mountpoint      FStype      Options Dump Pass
    11. /dev/label/rootfs0  /       ufs rw,noatime  1   1
    12. /dev/label/swap0    none        swap    sw  0   0
    13. /dev/label/var0     /var        ufs rw,noatime  1   1
    14. /dev/label/usr0     /usr        ufs rw,noatime  1   1
    15. procfs          /proc       procfs  rw      0   0
    16. linprocfs       /compat/linux/proc  linprocfs   rw      00
    17. homenas2:/mnt/dpool1    /mnt/nas2       nfs     rw,rsize=4096,noauto    0       0
    18. [root@ws5] ~# mount /mnt/nas2
    19. [tcp] homenas2:/mnt/dpool1: RPCPROG_MNT: RPC: Timed out
    20. ^C
    21. [root@ws5] ~# mount /mnt/nas2
    22. [tcp] homenas2:/mnt/dpool1: RPCPROG_MNT: RPC: Timed out
    23. ^C
    24. [root@ws5] ~#
    Code (text):
    1. [user1@homenas2] /> su - root
    2. Password:
    3. [root@homenas2] ~# tail -f /var/log/messages
    4. Feb  1 09:55:17 homenas2 freenas: Starting statd.
    5. Feb  1 09:55:17 homenas2 freenas[1741]: Executing: /usr/sbin/service lockd quietstart
    6. Feb  1 09:55:17 homenas2 freenas: Starting lockd.
    7. Feb  1 09:55:17 homenas2 freenas[1741]: Executing: /bin/pgrep nfsd
    8. Feb  2 05:14:12 homenas2 ntpd[1494]: kernel time sync status change 6001
    9. Feb  2 05:31:17 homenas2 ntpd[1494]: kernel time sync status change 2001
    10. Feb  2 07:30:57 homenas2 ntpd[1494]: kernel time sync status change 6001
    11. Feb  2 07:39:30 homenas2 ntpd[1494]: kernel time sync status change 2001
    12. Feb  3 07:47:49 homenas2 su: BAD SU user1 to root on /dev/pts/0
    13. Feb  3 07:47:55 homenas2 su: user1 to root on /dev/pts/0
    14. Feb  3 07:52:28 homenas2 mountd[14958]: mount request denied from 192.168.0.202 for /mnt/dpool1
    15. Feb  3 07:54:27 homenas2 freenas[1741]: Executing: /usr/sbin/service ix-nfsd quietstart
    16. Feb  3 07:54:27 homenas2 freenas: vfs.nfsrv.async: 0 -> 0
    17. Feb  3 07:54:27 homenas2 freenas[1741]: Executing: /usr/sbin/service mountd reload
    18. Feb  3 07:54:28 homenas2 freenas[1741]: Executing: /bin/pgrep nfsd
    I changed my settings for: 'Authorized network or IP addresses' from 192.168.0.0 (attempt to reference the subnet) to 192.168.0.202 (actual address of my workstation) and that seems to have gotten rid of the: 'mount request denied from 192.168.0.202' at the freenas server but .... still I have the RPC issue and no mounting at the workstation. I also changed the mapalluser to Root and mapallgroup to wheel. see second attachment: Screenshot - 02032012 - 08:31:47.jpg

    Code (text):
    1. [root@ws5] ~# mount /mnt/nas2
    2. [tcp] homenas2:/mnt/dpool1: RPCPROG_MNT: RPC: Timed out
    3. ^C
    4. [root@ws5] ~# mount /mnt/nas2
    5. [tcp] homenas2:/mnt/dpool1: RPCPROG_MNT: RPC: Timed out
    6. ^C
    7. [root@ws5] ~# date
    8. Fri Feb  3 08:32:56 EST 2012
    9. [root@ws5] ~# mount /mnt/nas2
    10. [tcp] homenas2:/mnt/dpool1: RPCPROG_MNT: RPC: Timed out
    11. [tcp] homenas2:/mnt/dpool1: RPCPROG_MNT: RPC: Timed out
    12. [tcp] homenas2:/mnt/dpool1: RPCPROG_MNT: RPC: Timed out
    13. ^C
    14.  
    Code (text):
    1. [root@homenas2] ~# ps -ax | grep rpc
    2.  1186  ??  Ss     0:00.14 /usr/sbin/rpcbind
    3. 15007  ??  Ss     0:00.11 /usr/sbin/rpc.statd
    4. 15025  ??  Ss     0:00.21 /usr/sbin/rpc.lockd
    5. 38645   0  R+     0:00.00 grep rpc
    Code (text):
    1. [root@ws5] ~# ps -ax | grep rpc
    2.  1833  ??  Is     0:00.01 /usr/sbin/rpcbind
    3. 35312   0  S+     0:00.00 grep rpc
    4.  
    5. [root@ws5] ~# cat /etc/rc.conf | grep nfs
    6. nfs_client_enable="YES"
    7.  
    8. [root@ws5] ~# ps -ax | grep nfs
    9. 35748   0  S+     0:00.00 grep nfs
    Thanks in advance for any assistance you can provide.
    http://forums.pcbsd.org/showthread.php?t=16152
    Ben

    Attached Files:

  2. bforest New Member

    Member Since:
    Jun 18, 2011
    Message Count:
    8
    Likes Received:
    0
    Trophy Points:
    0
    bforest, Feb 4, 2012

  3. bforest New Member

    Member Since:
    Jun 18, 2011
    Message Count:
    8
    Likes Received:
    0
    Trophy Points:
    0
    bforest, Feb 4, 2012

    I attempted to connect to the FreeNAS server (mount the same NFS share) on an old laptop but received the same RPCBIND Timeout error.

  4. bforest New Member

    Member Since:
    Jun 18, 2011
    Message Count:
    8
    Likes Received:
    0
    Trophy Points:
    0
    bforest, Feb 7, 2012

    Solved??

    Wow...

    I believe I have found "a" solution to the "RPCPROG_MNT: RPC: Timed out" issue. I found the following thread:

    http://forums.freebsd.org/showthread.php?t=14415

    Which basically told me to add the host IP and hostname of my workstation to the /etc/hosts file of the FreeNAS server. I did this and the share mounted immediately upon issuing the mount command.

    I am happy to have the share mounting now but... my workstations are DHCP so the address could change.

    I was hoping for a better solution. (I still don't completely understand the problem or the "why".) I could just change my DHCP to send specific IP's to specific machines but...

    Any thoughts please??
    Anyone reading these??

    Ben
  5. bforest New Member

    Member Since:
    Jun 18, 2011
    Message Count:
    8
    Likes Received:
    0
    Trophy Points:
    0
    bforest, Feb 8, 2012

    Ok... The above temporary fix is even more temporary because when I reboot the FreeNAS box the /etc/hosts file gets restored to the original version.

    Could someone tell me how to make persistent changes to the /etc/hosts file or is there somewhere in the GUI I can add these entries?

    My system boots off of a 4Gb USB flash drive.

    Code (text):
    1. :from /var/run/dmesg.boot:
    2. . . .
    3. da0: <hp v165w 1100> Removable Direct Access SCSI-0 device
    4. da0: 40.000MB/s transfers
    5. da0: 3894MB (7975296 512 byte sectors: 255H 63S/T 496C)
    6. . . .
    7. GEOM: da0s1: geometry does not match label (16h,63s != 255h,63s).
    8. . . .

Share This Page