One computer connects...the other doesn't

Discussion in 'New to FreeNAS?' started by rthomasson, Oct 2, 2012.

  1. Offline

    rthomasson

    Member Since:
    Oct 2, 2012
    Messages:
    7
    Message Count:
    7
    Likes Received:
    0
    Trophy Points:
    0
    rthomasson, Oct 2, 2012

    I just installed FreeNAS tonight. I got everything working perfectly (somewhat). My problem is that my laptop computer can connect to the FreeNAS folder with no issues. But, when I try to do the same with my wife's laptop, I get an error saying that it cannot find the path. Any ideas?

    Thanks for the help
  2. Offline

    ben FreeNAS Marketing Team

    Member Since:
    May 24, 2011
    Messages:
    372
    Message Count:
    372
    Likes Received:
    1
    Trophy Points:
    18
    Occupation:
    Technical Marketing Specialist at iXsystems, Inc.
    Location:
    Sunnyvale, CA
    ben, Oct 3, 2012

    FreeNAS version, share type, types of computers you're connecting with (hardware and OS), FreeNAS hardware and an outline of your network setup would help people give you a good answer.
  3. Offline

    rthomasson

    Member Since:
    Oct 2, 2012
    Messages:
    7
    Message Count:
    7
    Likes Received:
    0
    Trophy Points:
    0
    rthomasson, Oct 3, 2012

    Sure thing! Thanks

    My wife's computer is Sony VAIO laptop
    Intel Core i5 CPU 2.53 GHz
    RAM: 4GB
    OS: 64-bit Windows 7
    This is the computer that cannot see the FreeNAS that I set up. I am able to open a web browser and get to the FreeNAS GUI, but when I go to Windows Explorer and type \\<ip address> it says that Windows is not able to access it (network path was not found). I am able to go to a command prompt and ping the ip address successfully, but I expected this because I can access the GUI.

    My Computer is an HP g6 Laptop
    AMD A6-3400M APU with Radeon HD Graphics 1.40 GHz
    RAM: 6GB
    OS: 64-bit Windows 7
    This computer is able to connect just fine and see all the folders as well as the GUI

    We are running FreeNAS-8.0.3-RELEASE-x64 (9395)
    on a Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz
    with 3943MB of RAM
    OS Version: FreeBSD 8.2-RELEASE-p5
    We are using CIFS Sharing

    Need anything else?
  4. Offline

    leenux_tux FreeNAS Aware

    Member Since:
    Sep 3, 2011
    Messages:
    145
    Message Count:
    145
    Likes Received:
    4
    Trophy Points:
    18
    Occupation:
    Senior (AKA "OLD"!!) Technical Consultant
    Location:
    UK
    leenux_tux, Oct 4, 2012

    On the computer that can't connect try the following....

    Open up a command prompt.

    When open, enter "net use DRIVE_LETTER: \\IP_ADDRESS\SHARENAME /user:NAME_OF_USER_ON_FREENAS"

    Where

    DRIVE_LETTER is the drive you want to map to, i.e. W:
    IP_ADDRESS is the IP of the FreeNAS box.
    SHARENAME is the share you are connecting to
    NAME_OF_USER_ON_FREENAS is the user on FreenNAS who has access to the share.
    Do not include the double quotes

    For example...

    net use W: \\192.168.1.100\MOVIES /user:mythtv

    ######Important######### there is a space between W: and the first \

    Depending on how you have your security setup you may be asked for a password.

    If this works you can view the available shares via

    "net view \\IP_ADDRESS" from the command line

    Hope this works
  5. Offline

    rthomasson

    Member Since:
    Oct 2, 2012
    Messages:
    7
    Message Count:
    7
    Likes Received:
    0
    Trophy Points:
    0
    rthomasson, Oct 4, 2012

    OK, I got home tonight and I tried running the command that was provided, but the problem is that because the second computer (the Vaio) is not able to find the IP, I have not mapped a drive to it yet, so what would I use for the drive name/letter? Choosing random drives, I get either "The binding handle is invalid", or "the network path was not found".

    Second, I tried logging in to the FreeNAS server on my working computer using the same command. No matter which user I choose, I get "The local device name is already in use". Because now I have ran into another issue. Any files that were put there by another user, cannot be moved, deleted, or altered by another user eventhough I have given everyone read/write/execute permissions.

    Thank you for the help, I appreciate it.
  6. Offline

    leenux_tux FreeNAS Aware

    Member Since:
    Sep 3, 2011
    Messages:
    145
    Message Count:
    145
    Likes Received:
    4
    Trophy Points:
    18
    Occupation:
    Senior (AKA "OLD"!!) Technical Consultant
    Location:
    UK
    leenux_tux, Oct 5, 2012

    My mistake, I thought the laptop could ping the FreeNAS box..

    Sounds like you have a network connection issue with your wife's laptop ?

    From the command line on the laptop, what do you get back when you do "ipconfig" ? If it's connected to your local network you should get an IP address either for your wireless NIC or the LAN NIC (or both if they are both connected) something like..

    192.168.1.10 (for example, it all depends on how your router is setup).

    What is the IP address of your FreeNAS box ?

    What happens when you ping the IP address of the FreeNAS box from your wife's laptop ?

    Also, check out the default gateway settings for each, they should be the same
  7. Offline

    Stephens

    Member Since:
    Jun 19, 2012
    Messages:
    497
    Message Count:
    497
    Likes Received:
    1
    Trophy Points:
    0
    Stephens, Oct 5, 2012

    @leenux_tux I'm not sure you had the network assumptions wrong. He says in thread post #3 that not only can he ping the NAS from his wife's laptop, but he can access the NAS GUI using a web browser. So, he CAN access the NAS via IP when using the GUI or ping, but he's saying (for instance) "NET USE N: \\nas_ip_address\nas_share" fails with "the network path was not found". In other words, it can see the computer, but not the share.
  8. Offline

    rthomasson

    Member Since:
    Oct 2, 2012
    Messages:
    7
    Message Count:
    7
    Likes Received:
    0
    Trophy Points:
    0
    rthomasson, Oct 5, 2012

    Yes Stephens, exactly!

    I can get on the internet and I get pull up the NAS GUI on her computer. But when I try to access the share, it says that the "network path is not found". I am completely stumped on this one as I set up up exactly like my personal computer. One computer can access the share and the other one cannot.

    Any help would be greatly appreciated. Additionally, thank you far all the help so far!!
  9. Offline

    Stephens

    Member Since:
    Jun 19, 2012
    Messages:
    497
    Message Count:
    497
    Likes Received:
    1
    Trophy Points:
    0
    Stephens, Oct 5, 2012

    Show us what the share configuration looks like. If you take a screen cap, don't attached it to a message as it will resize it and we won't be able to read it. Host it somewhere like tinypic and paste a link (or in-line image) here. We also need to see what CIFS sharing looks like.

    For testing, you might want to enable guest access on the share, turn off CIFS services, turn CIFS services back on, reboot the laptop, then try accessing from your wife's laptop. Report if there's any change.
  10. Offline

    rthomasson

    Member Since:
    Oct 2, 2012
    Messages:
    7
    Message Count:
    7
    Likes Received:
    0
    Trophy Points:
    0
    rthomasson, Oct 9, 2012

    Hey guys,

    Sorry I didn't follow up immediately. I was away for the weekend. But I did take snapshots of everything that I have set up:

    Volume Permissions:
    http://i49.tinypic.com/igzvq0.jpg

    CIFS Share
    http://i50.tinypic.com/14jz4f9.png
    http://i46.tinypic.com/2uy38jn.jpg

    CIFS Service
    http://i45.tinypic.com/10r60yv.jpg
    http://i45.tinypic.com/9q89y0.jpg
    http://i47.tinypic.com/2w2ecf6.jpg

    Additionally, I have tried turning CIFS services off, rebooting FreeNAS, rebooting my computer, accessing the NAS from my wife's computer, and recently I have turned to drinking very heavily.

    Any help would be apprecaited, thanks!
  11. Offline

    burninmedia

    Member Since:
    Aug 16, 2012
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Atlanta, Georgia, United States
    burninmedia, Nov 7, 2012

    I am having the same issue
    I have a number of PCs that can connect to the NAS box.

    Server 2008 x86
    Laptop Windows 7 Pro x64
    HTPC Windows 8 x64 Pro
    Office Windows 8 x64 Pro <- problem box

    I keep getting a
    "System error 64 has occurred.

    The specified network name is no longer available."

    Can anyone shed some light as to why this one win8 box can't connect when my others can.
    I have tried turning off the NTLMv2, rejoin to domain, connect as different user, us IP in place of DNS name.
    Nothing is working. Help please.
  12. Offline

    leenux_tux FreeNAS Aware

    Member Since:
    Sep 3, 2011
    Messages:
    145
    Message Count:
    145
    Likes Received:
    4
    Trophy Points:
    18
    Occupation:
    Senior (AKA "OLD"!!) Technical Consultant
    Location:
    UK
    leenux_tux, Nov 7, 2012

  13. Offline

    burninmedia

    Member Since:
    Aug 16, 2012
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Atlanta, Georgia, United States
    burninmedia, Nov 7, 2012

    That doesn't work. Also on mt HTPC it is set to not defined. and I can connect to the NAS from there.
  14. Offline

    JaimieV FreeNAS Aware

    Member Since:
    Oct 12, 2012
    Messages:
    416
    Message Count:
    416
    Likes Received:
    0
    Trophy Points:
    16
    JaimieV, Nov 7, 2012

    Too late, but: The Samba in current FreeNAS doesn't need that set, since it supports NTLMv2.

    Do your two Windows machines use different antivirus and/or firewalls from each other? If they do, try disabling it on the troublesome machine temporarily.
  15. Offline

    burninmedia

    Member Since:
    Aug 16, 2012
    Messages:
    4
    Message Count:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Atlanta, Georgia, United States
    burninmedia, Nov 7, 2012

    SOLVED!

    OK, I have solved it after 4 hours of mucking around.
    I changed the setting below from Require signing to
    Network security: LDAP client signing requirement: Negotiate signing


    • Please note that I set the default Windows 7/8 setting of the policy to "NTLMv2 responses only"
  16. Offline

    JaimieV FreeNAS Aware

    Member Since:
    Oct 12, 2012
    Messages:
    416
    Message Count:
    416
    Likes Received:
    0
    Trophy Points:
    16
    JaimieV, Nov 7, 2012

    Boggle. LDAP should be completely irrelevant to shares... Still, there's Windows for you.

    Where's the setting exactly?

Share This Page