Permission problems with CIFS

Discussion in 'Sharing' started by CemeteryRidge, Jun 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    CemeteryRidge

    Member Since:
    Jun 16, 2011
    Messages:
    1
    Message Count:
    1
    Likes Received:
    0
    Trophy Points:
    0
    CemeteryRidge, Jun 16, 2011

    After i got freenas installed i created my software raid no problem. Created a local user with admin control. Then went to CIFS and set up Authentication:Local User, NetBIOS name:SERVER Workgroup:WORKGROUP and everything else was left alone. I set up 3 shares Files, Music and Movies with readonly off, browsable on, inherit permissions on, becycle bin on, hide dot files on, and host allow/deny blank. On my Win 7 Pro Rig i can see \\Server and the 3 shared files, Files, Music and Movies, But when i try to copy something to them i get "You need permission to perform this action"
  2. Offline

    Al562

    Member Since:
    Jun 19, 2011
    Messages:
    27
    Message Count:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    U.S.A.
    Al562, Jun 19, 2011

    Hi CemeteryRidge,

    Sounds like you need to authenticate in order to get access. W7 automatically sends the credentials of the logged in user, if these credentials are not accepted by the server you won't be allowed to do anything. Make sure your W7 login is configured on the server, if you don't want to do that then you'll have to explicitly login with different credentials by mapping the drives.

    This occurs because:
    You may also be interested in FAQ: Q: Why can I not login using Windows 7 and Vista clients when XP clients work fine with CIFS/SMB? It is not specific to FreeNAS 8 but may still help you if you have further issues.

    Regards,
    Al
Thread Status:
Not open for further replies.

Share This Page