PROBLEM Plex Media + FreeNas 9.1.1

Discussion in 'Plugins' started by ESDC, Oct 16, 2013.

  1. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 16, 2013

    Ok so I installed plex media as a plugin on 9.1.1 and followed the instructions here:
    Based on the instructions if I enter the GUI page I'm supposed to see this
    [​IMG]

    But instead I see a login page.
    I then registered for a plex account and I enter my username and password I registered. It then forwards me to a sad face and says "This media server is unavailable to you. Please check that you have permission to access this media server."
    I already changed ownership of the dataset to nobody:nobody and 777 permissions. So there has to be something wrong somewhere ... Help please?
  2. Offline

    zodiacq

    Member Since:
    Oct 16, 2013
    Messages:
    1
    Message Count:
    1
    Likes Received:
    0
    Trophy Points:
    1
    zodiacq, Oct 17, 2013

    Maybe it needs to connect to the internet, are your nameservers set up correctly, so that it can resolve the ip address?
  3. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 18, 2013

    Yes I entered the jail and got a ping reply from google. I also tried to use a different password on the login page and it can't connect so I don't think the Internet connection is a concern.

    Do I need a paid subscription from Plex in order for this plugin to work?
  4. Offline

    enemy85 FreeNAS Aware

    Member Since:
    Jun 10, 2011
    Messages:
    252
    Message Count:
    252
    Likes Received:
    11
    Trophy Points:
    18
    enemy85, Oct 18, 2013

    Hi, u don't need to pay a subscription because i installed the plugin few days ago and it works properly for me.
    I can access it from
    Http://plex_jail_ip:32400/web
  5. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 18, 2013

    Hello enemy85 thanks for the reply. Yeah that's what I thought so too. Did you see the login page on first startup? Or did it go straight in like the tutorial? I'm getting a login page but as soon as I enter the username and password it goes to this page
    I've tried chrome, ff and safari all 3 required me to login
  6. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 19, 2013

    Ok so to recreate this bug allow me to enumerate the steps I took to reinstall the plugin. Please comment what step I am doing wrong.

    1) Delete plugin
    2) Install plugin
    3) Enter plexmedia jail (jexec plex_1 /bin/tcsh)
    4) Add storage (source: freenas/plexmedia destination: plexjail/plexmedia)
    5) start plugin
    6) enter http://plex_jail_ip:32400/web
    7) login page (username password)
    8) enter username password registered
    9) "This media server is unavailable to you. Please check that you have permission to access this media server."
  7. Offline

    enemy85 FreeNAS Aware

    Member Since:
    Jun 10, 2011
    Messages:
    252
    Message Count:
    252
    Likes Received:
    11
    Trophy Points:
    18
    enemy85, Oct 19, 2013

    Hi, here it's what I did:

    1) I installed the plugin directly from FREENAS web GUI "plugin tab"
    2) automatically freenas created the plex_1 jail and installed the plugin in it
    (he settles the plex media server ip address on his own)
    3) then u add storage just selecting the media starting folder on freenas and the "media" destination folder in plex jail (note 1: the media folder in plax jail is created automatically; note 2 i just allowed permission to "0thers" at the media dataset in my freenas)

    after that i just started the service and entering "http://plex_jail_ip:32400/web" there was no login asking for me (i read somewhere that it's default disabled if installed in this way)
    then i registered at plex but just in orther to make it works from outside the freenas network.
    ESDC likes this.
  8. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 19, 2013

    Did you change the permission in the dataset? I set user and group to "nobody" and the mode as 777 (read write execute) everybody. Thanks again for the help
  9. Offline

    enemy85 FreeNAS Aware

    Member Since:
    Jun 10, 2011
    Messages:
    252
    Message Count:
    252
    Likes Received:
    11
    Trophy Points:
    18
    enemy85, Oct 19, 2013

    Mode 777 for me too, but with a user i created...try not to use "nobody" but an existing user u created. No any other ideas...
  10. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 19, 2013

  11. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 19, 2013

    Hmmm ... is it probably because I'm using LDAP? Let me try to disable that
  12. Offline

    enemy85 FreeNAS Aware

    Member Since:
    Jun 10, 2011
    Messages:
    252
    Message Count:
    252
    Likes Received:
    11
    Trophy Points:
    18
    enemy85, Oct 19, 2013

    I'm not using AD neither LDAP so i can't help in that case
  13. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 19, 2013

    So turning off directory services still didn't work ... I give up lol :p
  14. Offline

    nvader Newbie

    Member Since:
    Dec 20, 2012
    Messages:
    43
    Message Count:
    43
    Likes Received:
    0
    Trophy Points:
    6
    nvader, Oct 22, 2013

    try this url
    http://<your ip>:32400/web/index.html#!/dashboard
  15. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 22, 2013

  16. Offline

    TurbineSeaplane

    Member Since:
    Oct 29, 2013
    Messages:
    1
    Message Count:
    1
    Likes Received:
    0
    Trophy Points:
    1
    TurbineSeaplane, Oct 29, 2013

    Hi. Anyone ever figure anything out about this issue?
    I'm having the same problem.
    Simply can't login to myPlex at all. If I do, then my own media server is "unreachable" to me.
    Thanks.
  17. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Oct 29, 2013

    Glad to finally hear I'm not the only one with this problem lol :p no luck on my end yet
  18. Offline

    Myles Kennedy

    Member Since:
    Nov 1, 2013
    Messages:
    1
    Message Count:
    1
    Likes Received:
    2
    Trophy Points:
    3
    Myles Kennedy, Nov 1, 2013

    I can give you a workaround for this that I've used. In the jail edit the file Plex Media Server Preferences.xml file (in my case) located at:

    /usr/pbi/plexmediaserver-amd64/plexdata/Plex Media Server/Preferences.xml

    and add the attribute

    disableRemoteSecurity="1"

    to the Preferences element.

    Then give your server a restart and check again

    /usr/local/etc/rc.d/plexmediaserver restart

    Kingedgar and ESDC like this.
  19. Offline

    ESDC

    Member Since:
    Oct 16, 2013
    Messages:
    14
    Message Count:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ESDC, Nov 3, 2013

    FINALLY!!!!!!!!!!!!

    Thanks man! :D

Share This Page