Rsync Incrimental Backups from WHS 2011 to FreeNAS 8.0.4

Discussion in 'Configuration' started by aussiefitzy, Apr 16, 2012.

  1. aussiefitzy New Member

    Member Since:
    Apr 15, 2012
    Message Count:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Information Technology Senior Field Service Engine
    Location:
    Townsville, Queensland, Australia
    aussiefitzy, Apr 16, 2012

    I have been trying for ages to enable Incrimental Backups between my Windows Home Server 2011 to my FreeNAS 8.0.4. For some reson I can not get this to work in the FreeNAS GUI. I haver added a couple of screenshots of the Rsync configs an hope that someone can either point me in the right direction or have a fix for me.

    Cheers,

    Fitzy

    RsyncServices.jpg RsyncTask.jpg
  2. aussiefitzy New Member

    Member Since:
    Apr 15, 2012
    Message Count:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Information Technology Senior Field Service Engine
    Location:
    Townsville, Queensland, Australia
    aussiefitzy, Apr 17, 2012

    I've added th logs, if that helps ;-)

    Here's a snap shot of the log file RsyncLOG.jpg
  3. James FreeNAS Core Team

    Member Since:
    May 24, 2011
    Message Count:
    298
    Likes Received:
    21
    Trophy Points:
    18
    Occupation:
    iXsystems, Inc.
    Location:
    San Jose, CA
    Home page:
    James, Apr 19, 2012

    Does the following fix the problem?

    - in Remote Host, just put the IP (remove the ::AfterDark)

    If not, can you try making a module without a space in the name?
  4. aussiefitzy New Member

    Member Since:
    Apr 15, 2012
    Message Count:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Information Technology Senior Field Service Engine
    Location:
    Townsville, Queensland, Australia
    aussiefitzy, Jun 16, 2012

    192.168.2.15::AfterDark is what is in the Remote Host name

    If I don't have the folder name, how will it know to only look at that folder, on the WHS2011 box, as there are 10 folders I want to keep seperate?
  5. gmontalvo New Member

    Member Since:
    Sep 4, 2012
    Message Count:
    18
    Likes Received:
    0
    Trophy Points:
    0
    gmontalvo, Jan 20, 2013

    Coming from WHS, I found the rsync setup a little confusing.

    WHS does not have an rsync client/server (that I know of). You will have to use something like DeltaCopy, which is what I use to push files from my Windows PC's to FreeNAS.

    In DeltaCopy (on the WHS box), you setup what you want rsync to send to FreeNAS. On the FreeNAS side, you only have to configure the "Rsync Module" under the services tab (your first screen capture). If I understand your requirements correctly, you shouldn't need to configure anything in the second screen capture you provided.

    I don't logon to the forums terribly often, but I will check back to see how it goes for you. If I can help, I will. Good luck!
  6. fracai Member

    Member Since:
    Aug 22, 2012
    Message Count:
    441
    Likes Received:
    15
    Trophy Points:
    18
    fracai, Jan 22, 2013

    I realize this is a pretty old zombie, but in the event that it helps someone, somewhere, sometime...

    Looking at the log I see errors about unexpected local arguments "TV", and "Guys". That sounds like the backup path contained spaces that weren't properly escaped.

Share This Page