Setting Volume Permission Recursively does not work

Discussion in 'Bug Reporting' started by jjstecchino, Aug 27, 2011.

  1. Offline

    jjstecchino

    Member Since:
    May 29, 2011
    Messages:
    20
    Message Count:
    20
    Likes Received:
    0
    Trophy Points:
    1
    jjstecchino, Aug 27, 2011

    Tried on 8.01 B4 and nightly build 8r7404

    When trying to set permission recursively on either ZFS or UFS freenas fails with the following error :

    Code (text):
    1. NameError at /storage/mountpoint/permission/9/
    2.  
    3. global name 'ACL_Exception' is not defined
    4.  
    5. Request Method:     POST
    6. Request URL:    http://nas/storage/mountpoint/permission/9/
    7. Django Version:     1.3
    8. Exception Type:     NameError
    9. Exception Value:    
    10.  
    11. global name 'ACL_Exception' is not defined
    12.  
    13. Exception Location:     /usr/local/www/freenasUI/common/acl.py in __init__, line 84
    14. Python Executable:  /usr/local/bin/python
    15. Python Version:     2.7.2
    16. . . . . . . . . .
    17.  
    If the recursive box is unchecked permissions are set ok.
    All of my volumes were created on 8.0 and imported on 8.01. Permissions were set on 8.0. and still are set correctly. Just as I tried to set windows permissions recursively it gave the error. I tried then unix permission recursively and it gave error as well.
    Permission work only if the recursive box is not checked.

    Thanks
  2. Offline

    johnnyq

    Member Since:
    May 27, 2011
    Messages:
    8
    Message Count:
    8
    Likes Received:
    0
    Trophy Points:
    0
    johnnyq, Aug 28, 2011

    I got the same problem

    Ive been having this same problem ever since beta 3 of freenas I have 2 freenas boxes running, one at home and one at work and both boxes are unable to set permissions recursively I can chnage them manually using chmod on the command prompt. I am currently running R7419 64bit the newest and still have the same issue..
  3. Offline

    Nealsch

    Member Since:
    Sep 28, 2011
    Messages:
    2
    Message Count:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Nealsch, Sep 28, 2011

    Bump.
    I am also having this issue FN 8.0.1-RC2
  4. Offline

    califrag

    Member Since:
    Sep 9, 2011
    Messages:
    16
    Message Count:
    16
    Likes Received:
    1
    Trophy Points:
    1
    califrag, Sep 28, 2011

    Ahhhh so it wasn't just me either then! Thanks for posting this...

    I somehow nuked the permissions on my volumes when trying to 'set recursively'...

    Ended up just chmod -R 777 on my entire mount (yeah I know.....) but now i can access all my files without any issues.. heh heh
  5. Offline

    Nealsch

    Member Since:
    Sep 28, 2011
    Messages:
    2
    Message Count:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Nealsch, Sep 28, 2011

    That's funny! I ended up doing exactly that.
    What the heck, the FN is only accessible on my private network.
  6. Offline

    scottfreeze

    Member Since:
    Oct 21, 2011
    Messages:
    3
    Message Count:
    3
    Likes Received:
    0
    Trophy Points:
    1
    scottfreeze, Oct 21, 2011

    I am still having this issue in 8.0.2-RELEASE, with a dataset housed in a ZFS RAID-Z volume. If I check the "set recursively" box for the permissions on my dataset, the GUI just hangs, and the permissions don't get correctly set (in fact I think they end up changed to some other values than I entered altogether?!?). Only when the "set recursively" box is unchecked does the change permissions operation seem to complete successfully. Can anyone confirm that this is still a problem?
  7. Offline

    kaboom69

    Member Since:
    Oct 11, 2011
    Messages:
    11
    Message Count:
    11
    Likes Received:
    0
    Trophy Points:
    0
    kaboom69, Oct 26, 2011

    I have exactly the same issue as scottfreeze with 8.0.2-RELEASE.
    Is there a solution ?
  8. Offline

    William Grzybowski FreeNAS Guru

    Member Since:
    May 27, 2011
    Messages:
    1,659
    Message Count:
    1,659
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    Curitiba, Brazil
    William Grzybowski, Oct 26, 2011

    Enable Settings -> Advanced -> Show traceback, do the operation again and paste the error output (in 8.0.2-RELEASE, we don't need it for anything different)
  9. Offline

    shackrock Guest

    Member Since:
    shackrock, Nov 19, 2011

    Same issue as ScottFreeze for me.

    GUI hangs. I tried settings "traceback" as noted, but I can't see or do anything because the GUI hangs. I can refresh or hit the "X" but that's about it. And, the permissions don't get changed...
  10. Offline

    gcooper

    Member Since:
    Sep 23, 2011
    Messages:
    416
    Message Count:
    416
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Former iXsystems Software Developer
    gcooper, Jan 3, 2012

    Don't use the "set permissions recursively" option. It's still broken in 8.0.3 for a handful of cases I've run into in the past. I'll see if I can figure out the exact problem, but if you guys have a stable reproduction case or more details about the total number of files involved, the directory layout, etc, please pass it along.

    Thanks!
  11. Offline

    Ico747

    Member Since:
    Jan 5, 2012
    Messages:
    13
    Message Count:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Ico747, Jan 9, 2012

    I confirm - it does not work with 8.0.3
  12. Offline

    gcooper

    Member Since:
    Sep 23, 2011
    Messages:
    416
    Message Count:
    416
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Former iXsystems Software Developer
    gcooper, Jan 9, 2012

    Yeah.. this needs more work, but it will be 8.2.1+. For now, please trust your tool that you're using to set the permissions correctly (Explorer, Finder, console, etc).
  13. Offline

    Ico747

    Member Since:
    Jan 5, 2012
    Messages:
    13
    Message Count:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Ico747, Jan 10, 2012

    Tank you very much for your answer. I am new in freenas and freebsd. Do you mean that using other tools I could get the same result. Could you please give an example how to with console?
  14. Offline

    gcooper

    Member Since:
    Sep 23, 2011
    Messages:
    416
    Message Count:
    416
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Former iXsystems Software Developer
    gcooper, Jan 10, 2012

    Np.

    The best recommendation I can give is:

    1. Don't set permissions recursively and permissively (setting permissions non-recursively works well).
    2. Use your preferred weapon of choice to restrict permissions, whether it is Explorer, Finder, Konqueror, Thunar, etc. If you want to use the command line tools, here are some manpages for using chmod [1] and chown [2]. The setfacl/getfacl manpage is very incomplete (it doesn't describe all of the settable ACLs.. I have a PR open for that)

    1. http://www.freebsd.org/cgi/man.cgi?chmod
    2. http://www.freebsd.org/cgi/man.cgi?chown
  15. Offline

    KAI

    Member Since:
    Sep 29, 2011
    Messages:
    15
    Message Count:
    15
    Likes Received:
    0
    Trophy Points:
    1
    KAI, Mar 13, 2012

    Recursive permission still seems broken in 8.0.4 as well
  16. Offline

    Adub

    Member Since:
    Nov 7, 2011
    Messages:
    7
    Message Count:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Adub, Apr 23, 2012

    Indeed, I too am having issues when attempting to set permisions recursively via the GUI.

    If the dataset has any significant size at all (say 100GB), after click the "Change" button on the modal permissions window, the the window just hangs and sits there. I can close it, but none of the permissions are changed.

    Since this appears to be broken, I am wondering if it is perfectly safe to run a chown -R command on the dataset. Will it break any permissions issues with the ZFS dataset? Or will it work fine?

    Example : "chown -R nobody:storageaccess /mnt/storage/dataset" <- Is this safe?

    My freenas version is FreeNAS-8.0.4-RELEASE-x64 (10351).
  17. Offline

    ash

    Member Since:
    Apr 28, 2012
    Messages:
    8
    Message Count:
    8
    Likes Received:
    0
    Trophy Points:
    0
    ash, Apr 28, 2012

    with FreeNAS-8.0.4-RELEASE-p1-x64 the same issue not working from GUI - stacking without any message for long period of time without changing nothing
    only by using chown from console - ok
  18. Offline

    sjieke FreeNAS Aware

    Member Since:
    Jun 7, 2011
    Messages:
    100
    Message Count:
    100
    Likes Received:
    0
    Trophy Points:
    16
    sjieke, May 2, 2012

    I'm still using FreeNAS-8.0.3-p1 (Multimedia edition) and I succesfully changed permissions recursively on an entire dataset using the gui. It takes a very long time, but it gets the job done. If you watch the output of 'top', you will see that a python script gets a lot of cpu resources. That's the one changing the permissions. If it finishes and you then you check the permissions, you will see they are changed.

    So you just need to wait a very long time, depending on the size of your dataset.
  19. Offline

    ash

    Member Since:
    Apr 28, 2012
    Messages:
    8
    Message Count:
    8
    Likes Received:
    0
    Trophy Points:
    0
    ash, May 2, 2012

    agree, with FreeNAS-8.0.4-RELEASE-p1-x64 probably the same issue as stated by sjieke, I would say never was waiting till end of GUI operation, for huge amount of data it doing so long and really I don't see any sign of operation in progress.
    Using console chown, chmod working faster.

Share This Page