transmission plugin

Discussion in 'Plugins' started by matlock, Mar 21, 2012.

  1. Offline

    matlock FreeNAS Aware

    Member Since:
    Mar 2, 2012
    Messages:
    107
    Message Count:
    107
    Likes Received:
    0
    Trophy Points:
    16
    matlock, Mar 21, 2012

    Hey-
    I've looked around and know that I should have more configurable options within the Plugins->Configure Plugins -> transmission ... My only available options are in the attached screenshot.

    I've rebuilt freenas/re-downloaded all the pbi's and recreated the jail and run through the process of installing the plugin via the gui several times.

    Any suggestions?

    -Matlock

    Attached Files:

  2. Offline

    James FreeNAS Core Team

    Member Since:
    May 24, 2011
    Messages:
    295
    Message Count:
    295
    Likes Received:
    21
    Trophy Points:
    18
    Occupation:
    iXsystems, Inc.
    Location:
    San Jose, CA
    Home page:
    James, Mar 21, 2012

    Which options were you expecting to see that are missing? We could see about adding them to the PBI's edit.html file.
  3. Offline

    matlock FreeNAS Aware

    Member Since:
    Mar 2, 2012
    Messages:
    107
    Message Count:
    107
    Likes Received:
    0
    Trophy Points:
    16
    matlock, Mar 21, 2012

    Hm- by your response it would seem that I shouldn't be expecting to see more? I also just found
    http://forums.freenas.org/showthrea...LEASE_MULTIMEDIA&p=20055&viewfull=1#post20055

    not sure if this documentation pertains to 'me' yet but i'll take a closer look in just a moment.

    But the options I were expecting to see came from a wiki search i found about transmission. I've attached a screenshot and here is a link as well-
    http://doc.freenas.org/index.php/Plugins_Configuration#Transmission

    -Matlock

    **oh what a terrible screenshot... i'm removing that =) the screenshots just the options list from the http://doc.freenas.org page
  4. Offline

    Ismael Duarte Newbie

    Member Since:
    Jun 13, 2011
    Messages:
    92
    Message Count:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Occupation:
    Encarregado Geral, Ascensores e Escadas Rolantes
    Location:
    Seixal, Portugal, Portugal
    Ismael Duarte, Mar 21, 2012

    I think this is not ready yet.
    I've tried several times to get transmission to work without success.
    Anyone as success with this plugin with GUI ?
  5. Offline

    James FreeNAS Core Team

    Member Since:
    May 24, 2011
    Messages:
    295
    Message Count:
    295
    Likes Received:
    21
    Trophy Points:
    18
    Occupation:
    iXsystems, Inc.
    Location:
    San Jose, CA
    Home page:
    James, Mar 22, 2012

    Transmission has had some active commits over the past few days to fix issues. Please update this thread when beta3 is out if there are still issues so they can be resolved before release.
  6. Offline

    matlock FreeNAS Aware

    Member Since:
    Mar 2, 2012
    Messages:
    107
    Message Count:
    107
    Likes Received:
    0
    Trophy Points:
    16
    matlock, Mar 22, 2012

    I'll do just that.

    But in the meantime-
    Can someone who has installed the plugin reply here- I'd like to ask them to do me a favor for testing purposes.
  7. Offline

    timotao89

    Member Since:
    Mar 18, 2012
    Messages:
    3
    Message Count:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Software Test Engineer
    Location:
    Washington
    timotao89, Mar 22, 2012

    I've been able to install the transmission pbi and configure the options as discussed on: http://doc.freenas.org/index.php/Plugins_Configuration#Transmission. As of now I have access to the webfront end of transmission (default to port 9091).
    The configurable options should be found on: Services -> transmission -> edit.

    @matlock Let me know if you have any questions
  8. Offline

    matlock FreeNAS Aware

    Member Since:
    Mar 2, 2012
    Messages:
    107
    Message Count:
    107
    Likes Received:
    0
    Trophy Points:
    16
    matlock, Mar 22, 2012

    I have transmission running- but when I upload a .torrent, or use the link option- the torrent download fails saying

    Error: Read-only file system
    then goes on to list the directory in parenthesis that is read-only. How do I fix this?

    -Matlock
  9. Offline

    matlock FreeNAS Aware

    Member Since:
    Mar 2, 2012
    Messages:
    107
    Message Count:
    107
    Likes Received:
    0
    Trophy Points:
    16
    matlock, Mar 22, 2012

    YESSSSSS!!!! I GOT IT!
    Setup a watch folder- setup the download folder! its all working =) !!!

    -Matlock
  10. Offline

    matlock FreeNAS Aware

    Member Since:
    Mar 2, 2012
    Messages:
    107
    Message Count:
    107
    Likes Received:
    0
    Trophy Points:
    16
    matlock, Mar 22, 2012

    I'll put together a write-up of my experience and how I got transmission 2.42 running on freenas 8.2 beta2
    *** I could not get the plugin installation method working for me- but this seemed to be a good work around. BUT- when BETA3 comes around- i'll be giving that a shot still.

    Some software you'll need, winscp
    http://winscp.net/eng/download.php

    and putty
    http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

    Make sure you have setup- and enabled ssh on your freenas.

    First follow the directions located here to get transmission installed and configured, for the most part. I ran into some issues with these directions- and hopefully I can answer some questions based off my experience thus far.
    http://unwittinglyrad.com/2012/01/28/guide-transmission-2-42-on-freenas-8/

    After following the above links instruction to get transmission installed- the first issue I encountered was an unauthorized ip error.

    I had quite a hard time figuring out how to get passed this and heres what I had to do.

    Via putty, i had stop the transmission-daemon. In the first parts of step 2c, you had turned the daemon on- go back and turn it off.

    *Note that when you first ssh into freenas- to set the mount -w / command

    (nano /conf/base/etc/rc.conf find the transmission_enable="YES" and set to "NO" you'll have to commit the changes CTRL+O followed by pressing enter on your keyboard to save the changes then ctrl+x to exit nano, type in reboot- to reboot freenas )

    Out of habit- i rebooted at this point.

    Started freenas back up- again, via putty, ssh'd into freenas,(dont forget the mount -w / command) and went to my settings.json file.

    If your unsure where this settings.json file is, you can use winscp to ssh into freenas and do a 'find' for the file. i'm not certain, but i'm guessing it'll be in the same place for you as it was for me which was /mnt/"my volume name"/torrents/settings.json

    to open the settings file to edit with putty type
    nano /mnt/your volume name/torrents/settings.json press enter
    within the settings.json file, you find "rpc-whitelist-enabled": true, and change from true to false. dont forget to commit the changes by pressing ctrl+o followed by enter. ctrl+x will get you out of nano.

    In retrospect, i believe you can set the download folder via the web interface- and so the next step may not be necessary.

    but at this point to save you some more headaches while your still in the settings.json file, go up to the "download-dir": field and this was set to //download for me, change this to //mnt/your volume name/your downloads folder you have given www user and www group read/write priveleges to.

    I also created a watch folder in the settings.json file. to do this i added the following to the end of the settings list

    "watch-dir": "//mnt/my volume name/torrents/torrents",
    "watch-dir-enabled": true
    }

    settings.json.PNG

    after doing all of this, i rebooted, ssh'd again into freenas with putty, did
    mount -w /
    then went back into nano /conf/base/etc/rc.conf and for the transmission_enable="NO" changed "no" to "YES"

    ctrl+O to apply changes followed by enter, then ctrl+x to exit nano, then typed reboot... to reboot... yet again.



    .... when you log back into freenas, and check system processes, you should see your transmission-daemon running.
    You should be able to also access the transmission webui via
    freenas-ip:9091

    drop a torrent file into your watch folder, and it should go...





    This is my first writeup of any kind- let me know how i did =)

    -matlock
  11. Offline

    Stephen McGovern

    Member Since:
    Apr 1, 2012
    Messages:
    8
    Message Count:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Leixlip, Ireland
    Stephen McGovern, Apr 10, 2012

    Not sure if anyone else has seen this, but transmission keeps disappearing from Services for me. Both minidlna and firefly appear, but transmission seems to disappear after a reboot or two. Deleting it, rebooting, and re-installing the plugin works, but not for long.
  12. Offline

    ikke Newbie

    Member Since:
    Apr 22, 2012
    Messages:
    26
    Message Count:
    26
    Likes Received:
    0
    Trophy Points:
    6
    ikke, Apr 24, 2012

    Can you please verify the download folder part? I just configured transmission plugin and used it succesfully. Except that it doesn't store the download folder into .json file. It stores the other parameters just fine. This causes it to download into jail, instead to a dataset location i have configured for it.
  13. Offline

    ikke Newbie

    Member Since:
    Apr 22, 2012
    Messages:
    26
    Message Count:
    26
    Likes Received:
    0
    Trophy Points:
    6
    ikke, Apr 24, 2012

    Sorry, I found from trac that it's fixed already.

Share This Page