WOL Realtek 8111E

Discussion in 'Networking' started by sebile, Feb 2, 2012.

  1. Offline

    sebile

    Member Since:
    Feb 2, 2012
    Messages:
    11
    Message Count:
    11
    Likes Received:
    0
    Trophy Points:
    1
    sebile, Feb 2, 2012

    Hi,

    I've been using Freenas 8 since half a year and I'm very happy with it.

    One problem that bothers me is that WakeOnLan is not supported on my Chipset. (Realtek 8168E / 8111E)

    I read all the threads on this forum about WOL but there hasn't been a solution until now.

    Today I found the following thread on the FreeBSD Forums (starts with post no. 15)

    http://forums.freebsd.org/showthread.php?t=28730

    It seems there was an error in the driver(if_re) which is patched in revision 230315.

    --> My question is if this patch is applied to a future FreeNAS update and when this will happen.
    --> If not would it be possible to patch the file individually?


    Thank you

    sebile
  2. Offline

    louisk FreeNAS Aware

    Member Since:
    Aug 10, 2011
    Messages:
    431
    Message Count:
    431
    Likes Received:
    2
    Trophy Points:
    18
    Occupation:
    Professional Nerd
    Location:
    Portland, OR area
    Home page:
    louisk, Feb 2, 2012

    It would make it into FreeNAS that is based on (future release of) FreeBSD 8.3, or 9.x. According to the RE page, 8.3 is scheduled for March. Whether they make that or not is a different story, and even if they do, it will still require effort to get FreeNAS apps and such running on it, so I would not expect it before June at the earliest.

    Yes, you can always do your own build of FreeNAS.
  3. Offline

    sebile

    Member Since:
    Feb 2, 2012
    Messages:
    11
    Message Count:
    11
    Likes Received:
    0
    Trophy Points:
    1
    sebile, Feb 2, 2012

    Thanks!

    Then I'll start working on it :)

    If I do my own build, how complicated is it to do an update (when FreeNAS 8.2 gets released for example) ?

    Can I update my running system with my own build now or do I have to make a new installation?
  4. Offline

    louisk FreeNAS Aware

    Member Since:
    Aug 10, 2011
    Messages:
    431
    Message Count:
    431
    Likes Received:
    2
    Trophy Points:
    18
    Occupation:
    Professional Nerd
    Location:
    Portland, OR area
    Home page:
    louisk, Feb 2, 2012

    I would suggest that for either type of *upgrade*, you backup the config. That way, if the upgrade fails, you can always do a clean install, and restore the config.

    If the only change is the re driver, you should be able to work interchangeably between your builds and official builds. That said, I would test it out with something like Fusion/Workstation before you do it to your production system.
  5. Offline

    Fre29

    Member Since:
    Feb 23, 2012
    Messages:
    1
    Message Count:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Fre29, Feb 23, 2012

    hello
    I have the same problem with and an MSI E350IE45 mothercard / Realtek 8168E / 8111E
    with alls versions of freenas 7, 8 ...WOL never work, I bought this card to improve performance but
    i cant use it
    if you have a new driver or something else for freenas
    thanks
  6. Offline

    zyo

    Member Since:
    Oct 8, 2011
    Messages:
    30
    Message Count:
    30
    Likes Received:
    0
    Trophy Points:
    0
    zyo, Apr 25, 2012

    Same problem here,

    ASUS fusion E35M1I board, if I shut down the system in Freenas WOL will never work, if I shut it down during BIOS boot sequence WOL works.

    It must be something in freebsd shutdown sequence that tells the integrated lan controller not to listen to WOL anymore (the corresponding light on my router is turned off in this case).
  7. Offline

    ProtoSD FreeNAS Guru

    Member Since:
    Jul 1, 2011
    Messages:
    3,359
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Apr 25, 2012

    Try this from the command line and see if you can wake it after:

    shutdown -h now (FreeNAS does shutdown -p now)
  8. Offline

    zyo

    Member Since:
    Oct 8, 2011
    Messages:
    30
    Message Count:
    30
    Likes Received:
    0
    Trophy Points:
    0
    zyo, Apr 25, 2012

    Will try tonight, problem is once I get the motherboard to this state the only way to get WOL back working again is through clearing CMOS (even load default bios settings doesnt work)
    So Im gonna have to open the case up and pull the battery out....

    Same setup with SuperMicro ATOM board (dual intel NIC) is working 100%, could be something to do with ASUS's implementation.
  9. Offline

    zyo

    Member Since:
    Oct 8, 2011
    Messages:
    30
    Message Count:
    30
    Likes Received:
    0
    Trophy Points:
    0
    zyo, Apr 25, 2012

    Hmm, it doesnt shutdown properly (power still on, requires me to press any key but nothing happens when I do)

    Press the power will say something like fail to enter S5 power down.
  10. Offline

    ProtoSD FreeNAS Guru

    Member Since:
    Jul 1, 2011
    Messages:
    3,359
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Apr 25, 2012

    You forgot to put the "now". "shutdown -h now"
  11. Offline

    ProtoSD FreeNAS Guru

    Member Since:
    Jul 1, 2011
    Messages:
    3,359
    Message Count:
    3,359
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Leaving FreeNAS
    ProtoSD, Apr 25, 2012

    You forgot to put the "now". "shutdown -h now"
  12. Offline

    zyo

    Member Since:
    Oct 8, 2011
    Messages:
    30
    Message Count:
    30
    Likes Received:
    0
    Trophy Points:
    0
    zyo, Apr 25, 2012

    calm down lol :)

    put now there
    system doesnt power down properly, asks me to "press any key" but nothing happens when I do.
  13. Offline

    zyo

    Member Since:
    Oct 8, 2011
    Messages:
    30
    Message Count:
    30
    Likes Received:
    0
    Trophy Points:
    0
    zyo, Apr 25, 2012

    I wonder if that patch is in FreeBSD 8.3 and will be in the next FreeNas release.
  14. Offline

    mrME

    Member Since:
    Jan 4, 2012
    Messages:
    18
    Message Count:
    18
    Likes Received:
    0
    Trophy Points:
    0
    mrME, May 1, 2012

    Could never get WOL to work with the on board Realtek NIC so just got an Intel NIC works perfectly. Or you could just use an RTC alarm or whatever your BIOS calls it to turn on at a certain time.


    specs.....
    Freenas 8.0.2 {installed on a Scandisk Cruzer Fit 8GB USB}
    ASROCK E350M1 {CPU fan lvl 1 in BIOS}
    Pareema 4GB (2 x 2GB)
    Intel EXPI9301CTBLK NIC
    4 - WD20EARS 2TB HDD
    1 - SAMSUNG Spinpoint 2.5" 1TB {via Esata port}
    picoPSU-150-XT PowerSupply
    Raidmax ITX case
    1 - Noctua NF-R8-1800 {lvl 1 manual speed control in BIOS}
  15. Offline

    sebile

    Member Since:
    Feb 2, 2012
    Messages:
    11
    Message Count:
    11
    Likes Received:
    0
    Trophy Points:
    1
    sebile, May 2, 2012

    The patch for realtek 8111e is included in FreeBSD 8.3
    I've succesfully built myself a custom freenas 8.0.3 and am now waiting for 8.3 to be released to update my System
  16. Offline

    zyo

    Member Since:
    Oct 8, 2011
    Messages:
    30
    Message Count:
    30
    Likes Received:
    0
    Trophy Points:
    0
    zyo, May 2, 2012

    Have you confirmed that fix is effective?
  17. Offline

    sebile

    Member Since:
    Feb 2, 2012
    Messages:
    11
    Message Count:
    11
    Likes Received:
    0
    Trophy Points:
    1
    sebile, May 3, 2012

    yes, wol is working perfectly for me since then :)
  18. Offline

    zyo

    Member Since:
    Oct 8, 2011
    Messages:
    30
    Message Count:
    30
    Likes Received:
    0
    Trophy Points:
    0
    zyo, May 3, 2012

    Great, think I will wait till 8.3 then.
  19. Offline

    pakpenyo

    Member Since:
    Jul 30, 2012
    Messages:
    13
    Message Count:
    13
    Likes Received:
    0
    Trophy Points:
    0
    pakpenyo, Sep 5, 2012

    Wol is working perfectly with 8.3beta1 with completely shutdown (shutdown -p now, NOT shutdown -h now).

    ASUS M5A78L-MLX

Share This Page